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PHẦN 1: THIẾT KẾ KẾT CẤU BẰNG PHẦN MỀM SAP2000

CHƯƠNG 1. TỔNG QUAN VỀ PHẦN MỀM SAP2000

1.1 Giới thiệu tóm tắt về phần mềm SAP2000


SAP (Structural Analysic Program) là họ chương trình phân tích kết cấu do Giáo sư Edward L. Wilson nghiên cứu và phát triển tại Đại học California, Berkeley Hoa Kỳ. SAP được thương mại hóa bởi hãng CSI (Computer & Structure Inc) với phiên bản đầu tiên ra đời vào năm 1970. Từ đó đến nay SAP luôn được mở rộng và bổ sung liên tục. 


Hệ chương trình SAP du nhập vào Việt Nam từ những năm 1990 với các phiên bản như SAP86, SAP90, SAP2000. Phiên bản SAP2000 hoạt động hoàn toàn trong môi trường Windows và được giảng dạy chính thức cho các sinh viên ngành xây dựng công trình tại các trường đại học ở Việt Nam. Đã có nhiều kết cấu công trình thực tế ở Việt Nam được phân tích và thiết kế bằng chương trình SAP2000. 


SAP2000 hiện tại với nhiều tính năng mạnh trong phân tích và thiết kế có thể áp dụng cho rất nhiều dạng công trình khác nhau như kết cấu dân dụng, kết cấu công trình biển, kết cấu cầu...Bổ sung thêm các phần tử mẫu và khả năng phân tích kết cấu phi tuyến cũng như bổ sung nhiều dạng kết cấu đặc biệt như cầu dầm hộp dự ứng lực thi công phân đoạn,cầu dây văng, cầu dây võng, phân tích động đất, phân tích kết cấu giàn khoan trên biển...
1.2 Khả năng của phần mềm SAP2000


Trong SAP2000 người dùng có thể mô tả nhiều loại tải trọng khác nhau như lực tập trung, lực phân bố đều hoặc hình thang, tải trọng do nhiệt độ, tải trọng do phổ gia tốc, tải trọng điều hòa và tải trọng di động...


Các loại bài toán kết cấu mà SAP2000 có thể thực hiện gồm có:

· Bài toán phân tích tĩnh (static analysis)

· Bài toán tính tần số dao động riêng và các dạng dao động (modal analysis)

· Bài toán đáp ứng động lực học (response analysis) với tải trọng ngoài thay đổi theo thời gian hay phổ gia tốc.

1.3 Yêu cầu về hệ thống

SAP2000 phiên bản 14. hiện nay được sử dụng phổ biến, yêu cầu về cấu hình hệ thống như sau:


Bộ vi xử lý (CPU): Tối thiểu Intel Pentium 4 hoặc AMD Athlon 64. Nên dùng: Intel Core 2 Duo, AMD Athlon 64 X2, hoặc hơn


Hệ điều hành: Tối thiểu Microsoft® Windows XP Service Pack 2 hoặc Microsoft® Windows Vista, phiên bản 32- và 64-bit


Bộ nhớ RAM: Tối thiểu 1 GB cho hệ điều hành Microsoft® Windows XP Service Pack 2, 2 GB cho hệ điều hành Microsoft® Windows Vista. Kiến nghị: 2 to 4 GB cho hệ điều hành 32-bit, 4 GB hoặc hơn cho hệ điều hành 64-bit.


Dung lượng ổ cứng còn trống: 6 GB để cài đặt chương trình, cộng thêm dung lượng yêu cầu để chạy chương trình, chứa các file mô hình và kết quả phân tích.


Card đồ họa: Hỗ trợ độ phân giải 1024×768. Khuyến cáo: Dùng card đồ họa rời ATI / NVIDIA GPU và  RAM đồ họa chuyên dụng.
1.4 Trình tự phân tích kết cấu bằng SAP2000
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CHƯƠNG 2. CÁC QUY ĐỊNH CHUNG VỀ PHẦN MỀM SAP2000
2.1 Đơn vị sử dụng


Hệ đơn vị bao gồm đơn vị lực, chiều dài, nhiệt độ và thời gian.


- Lực: N, kN, lb, kip, Kgf, Tonf


- Chiều dài : m, cm, mm, ft, in


- Nhiệt độ : F, C


- Thời gian : sec


Vào góc dưới phía bên phải màn hình:
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2.2 Hệ tọa độ

2.2.1 Hệ tọa độ tổng thể (Global coordinate system)


- Các trục của hệ tọa độ tổng thể được quy ước là các trục X, Y, Z trong SAP2000 hệ tọa độ này có tên là GLOBAL.

[image: image3.png]




- Hệ tọa độ tổng thể có thể là hệ tọa độ vuông góc (Cartesian) và hệ tọa độ trụ Cylindrical)

[image: image4.png]
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Mặt bằng lưới hệ tọa độ vuông góc và hệ tọa độ trụ

2.2.2 Hệ tọa độ bổ sung

Hệ tọa độ bổ sung được dùng để dễ dàng cho quá trình mô hình một bộ phận nào đó của kết cấu. 

Define -> Coordinate Systems/Grids … -> Add New System
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2.2.3 Hệ tọa độ địa phương

Mỗi thành phần cơ bản của kết cấu (nút, phần tử, hay ràng buộc chuyển vị) đều có hệ tọa độ địa phương của chính nó. Các trục của hệ tọa độ địa phương được ký hiệu các trục 1, 2, 3. Hệ tọa độ địa phương phần tử 1-2-3 liên quan với hệ tọa độ tổng quát X-Y-Z. Cả hai hệ tọa độ đều tuân theo quy tắc bàn tay phải. trong hầu hết các kết cấu, hệ tọa độ địa phương xác định đơn giản bằng cách dùng hướng mặc định và góc tọa độ phần tử thanh. Trục 1 đỏ; trục 2 trắng; trục 3 xanh. (Ví dụ khi tính dầm dùng V2, M3, V2:Là lưc cắt theo phương trục 2(trắng),M3:Là mômen quay quanh trục 3(xanh)).

Trục dọc 1 luôn luôn là trục dọc theo phần tử, hướng dương từ đầu i đến đầu j. Mặt phẳng 1-2 thường là mặt làm việc chính của thanh. Hướng mặc định của trục 2 và 3 được xác định theo quan hệ giữa trục 1 và trục Z của hệ tọa độ tổng thể.
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Hệ tọa độ địa phương của phần tử thanh
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Hệ tọa độ địa phương của phần tử tấm

2.3 Những công cụ hỗ trợ xây dựng mô hình

2.3.1 Công cụ dùng để vẽ

a. Vẽ phần tử nút (Joint)

Cách 1: Draw menu → Draw Speccial Joint
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Cách 2: Click biểu tượng [image: image13.png]


 trên thanh công cụ Draw:
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b. Vẽ phần tử thanh (Frame)

Cách 1: Draw menu → Draw Frame/Cable/Tendon
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Cách 2: Click biểu tượng [image: image16.png]


 trên thanh công cụ Draw:
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Cách 3: Vẽ nhanh phần tử bằng cách Click vào một đoạn đường lưới mà phần tử thanh sẽ nằm trên đó. Dùng biểu tượng vẽ nhanh [image: image18.png]


 trên thanh công cụ Draw:
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c. Vẽ phần tử tấm vỏ (Shell)

Cách 1: Draw menu → Draw Poly Area
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Cách 2: Click biểu tượng [image: image21.png]


 trên thanh công cụ Draw:
 [image: image22.png]



Cách 3: Vẽ phần tử bằng cách tạo thành ô cửa sổ hình chữ nhật bao trùm lấy đường lưới cần vẽ phần tử tấm vỏ. Dùng biểu tượng [image: image23.png]


 trên thanh công cụ Draw:
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Cách 4: Vẽ nhanh phần tử bằng cách Click vào vùng đường lưới bao quanh phần tử tấm vỏ. Dùng biểu tượng vẽ nhanh [image: image25.png]


 trên thanh công cụ Draw:
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d. Xóa phần tử nút, thanh, tấm vỏ (Delete)

Chọn phần tử cần xóa, nhấn phím Delete

e. Làm sạch màn hình (Refresh Window)

[image: image671.png]


Sau khi xóa bất kỳ một phần tử nào thì trên màn hình còn lại những điểm, để làm sạch màn hình nhấn vào biểu tượng [image: image27.png]


 trên thanh công cụ
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2.3.2 Công cụ nhân bản phần tử

a. Nhân bản phần tử theo tuyến tính (Linear)

Bước 1 : Chọn đối tượng cần nhân bản
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     [image: image30.png]




Kết cấu ban đầu




Phần tử được chọn

Bước 2 : Click menu Edid → Replicate


Hộp thoại Replicate xuất hiện, chọn Tab Linear
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Icrements dx, dy, dz: Khoảng cách phần tử nhân bản di chuyển tới.


Number: Số phần tử cần nhân bản.
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Sau khi Replicate
b. Nhân bản phần tử theo cung tròn (Radial)

Bước 1 : Chọn đối tượng cần nhân bản
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Trước khi Replicate


Phần tử được chọn
Bước 2 : Click menu Edid → Replicate


Hộp thoại Replicate xuất hiện, chọn Tab Radial
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Parallel to X, Parallel to Y, Parallel to Z, 3D line: Phần tử được nhân bản quay quanh trục X, Y, Z và 2 điểm trong không gian


Number: Số phần tử cần nhân bản.


Angle: Góc cần nhân bản
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Sau khi Replicate
c. Nhân bản đối tượng đối xứng qua mặt phẳng (Mirror)

Bước 1 : Chọn đối tượng cần nhân bản
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Trước khi Replicate


Phần tử được chọn
Bước 2 : Click menu Edit → Replicate


Hộp thoại Replicate xuất hiện, chọn Tab Mirror
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Sau khi Replicate
2.3.3 Chia nhỏ phần tử

a. Chia nhỏ phần tử thanh

Bước 1 : Chọn đối tượng cần chia nhỏ
Bước 2 : Click menu Edit → Edit Lines →Devide Frames [image: image41.png]



Bước 3 : Hộp thoại Devide Selected Frames:


Number of Frames: Số phân đoạn cần chia.


Last/First Length Ratio: Tỷ lệ chia.


Break at intersections with selected Joints, Frames, Area Edges and Solid Edges: Phần tử sẽ được chia tại vị trí giao nhau.


...
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Trước khi chia
[image: image44.png]



Sau khi chia
b. Chia nhỏ phần tử tấm vỏ

Bước 1 : Chọn đối tượng cần nhân bản
Bước 2 : Click menu Edit → Edit Areas →Devide Areas [image: image45.png]
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Trước khi chia



Sau khi chia
2.3.4 Ghép phần tử

a. Ghép phần tử thanh (Joint Frames)

Bước 1 : Chọn đối tượng cần nhân bản

Bước 2 : Click menu Edit → Edit Lines → Join Frames [image: image49.png]
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Trước khi ghép
[image: image51.png]



Sau khi ghép
b. Ghép phần tử nút (Merge Joints)

Trong quá trình xây dựng kết cấu bằng công cụ vẽ, nếu khoảng cách giữa hai phần tử nhỏ hơn 2,54mm (0,1Inch, đây là giá trị mặc định của chương trình) thì chương trình sẽ tự động ghép hai nút lại với nhau thành một nút. Vì một lý do nào đó mà khoảng cách giữa hai nút lớn hơn giá trị mặc định, người sử dụng muốn ghép chúng lại với nhau thành một thì thực hiện:

Bước 1 : Chọn đối tượng cần nhân bản

Bước 2 : Click menu Edit → Edit Points → Merge Joint [image: image52.png]
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Merge Tolerance: Giá trị khoảng cách của nút cần ghép
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Trước khi ghép



Sau khi ghép
2.4 Xây dựng mô hình từ thư viện


Dựa vào các mô hình mẫu, người sử dụng chọn mô hình nào phù hợp với mô hình kết cấu cần tính:

	STT
	TÊN MÔ HÌNH MẪU
	Ý NGHĨA

	1
	Grid Only
	Tạo mô hình từ các đường lưới

	2
	Beam
	Dầm

	3
	2D Trusses
	Giàn phẳng

	4
	3D Trusses
	Giàn không gian

	5
	2D Frames
	Khung phẳng

	6
	3D Frames
	Khung không gian

	7
	Wall
	Vách cứng

	8
	Flat Slab
	Sàn

	9
	Shells
	Tấm vỏ

	10
	Staircases
	Cầu thang

	11
	Storage Structures
	Bể nước

	12
	Underground Concrete
	Bể ngầm

	13
	Solid Models
	Khối

	14
	Cable Bridges
	Cầu treo

	15
	Caltrans-BAG
	Cầu

	16
	Bridge Wizard
	Cầu

	17
	Pipes and Plates
	Ống, tấm vỏ


2.4.1 Bài toán dầm

Bước 1 : Click menu File → New Model hoặc nhấp biểu tượng [image: image56.png]


, hộp thoại New Model xuất hiện
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Bước 2 : Click chọn mô hình Beam
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2.4.2 Bài toán khung phẳng

Bước 1 : Click menu File → New Model hoặc nhấp biểu tượng [image: image59.png]


, hộp thoại New Model xuất hiện
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Bước 2 : Click chọn mô hình 2D Frames

[image: image61.png]2D Frames

2D Frame Type FotalFrame Dimensions
Potal Nurbe of Stoies [2
Number of Bays [7 Baywidh 5

I~ Use Custom Giid Spacing and Locate Drigin

Section Propeties

Beams [Default <]+

Columns [Dafauit <]+

W Restaints oK Cancel

Story Height





Number of Stories: Số tầng

Number of Bays: Số nhịp

Story Height: Chiều cao tầng

Bay Width: Bề rộng nhịp

2.4.3 Bài toán khung không gian

Bước 1 : Click menu File → New Model hoặc nhấp biểu tượng [image: image62.png]


, hộp thoại New Model xuất hiện
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Bước 2 : Click chọn mô hình 3D Frames, chọn Beam-Slab Buildings
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Number of Stories: Số tầng

Number of Bays, X: Số nhịp theo phương trục X

Number of Bays, Y: Số nhịp theo phương trục Y

Number of Divisions, X: Số khoảng phần tử sàn chia theo phương trục X

Story Height: Chiều cao tầng

Bay Width, X: Bề rộng nhịp theo phương trục X

Bay Width, Y: Bề rộng nhịp theo phương trục Y

Number of Divisions, Y: Số khoảng phần tử sàn chia theo phương trục Y

2.4.4 Tạo mô hình từ đường lưới

Bước 1 : Click menu File → New Model hoặc nhấp biểu tượng [image: image65.png]


, hộp thoại New Model xuất hiện

Bước 2 : Click chọn Grid Only
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Cartesian: Hệ trục tọa độ vuông góc

Cylindrical: hệ trục toạn độ trụ

Number of Grid Lines:

X, Y, Z direction: Số đường lưới theo các phương X, Y, Z

Along Radius, along Theta, along Z: Số đường lưới theo bán kính, góc theta và cao độ Z

Grid Spacing:

X, Y, Z direction: Khoảng cách giữa hai đường lưới theo các phương X, Y, Z

Along Radius, along Theta, along Z: Khoảng cách giữa hai đường lưới theo bán kính, góc theta và cao độ Z

2.4.5 Hiệu chỉnh lưới phần tử

Cách 1: Click menu Define → Coordinate Systems/Grids → Modify/Show System

Cách 2: Click đúp vào vị trí đường lưới cần hiệu chỉnh
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X Grid Data, Y Grid Data, Z Grid Data: Hiển thị các đường lưới theo trục X, Y, Z

Grid ID: Tạo đường lưới

Ordinate: Tọa độ đường lưới theo hệ tọa độ tổng thể

Line type: Dạng đương lưới (chính, phụ)

Visibily: Đặc tính của đường lưới ẩn (hide) hoặc hiện (show)

Bubble Loc: Vị trí thể hiện tên trục

Grid Color: Màu hiện hành của đương lưới

Units: Đơn vị đo

Display Grid Lines: Thể hiện khoảng cách giữa các đường lưới theo các chế độ

Ordinates: Giá trị của đường lưới so với hệ tọa độ tổng thể

Spacing: Giá trị khoảng cách giữa các đường lưới

Hide All Grid Lines: Ẩn tất cả các đường lưới

Glue to Grid Lines: Di chuyển phần tử nút và đường lưới

Reset to Default Color: Thiết lập lại màu mặc định

Reorder Ordinates: Sắp xếp lại lưới tọa độ

2.5 Sơ đồ tính kết cấu

Mô hình hóa kết cấu với phần mềm được phát triển theo hai hướng. Hướng thứ nhất là mô hình hóa gần đúng kết cấu thực với một phương pháp tính gần đúng để tính toán ra nội lực, chuyển vị, dao động, phản lực... phục vụ cho công tác thiết kế. Hướng thứ hai là xây dựng các bài toán giống sơ đồ thực chất nhất từ việc mô hình vật liệu bê tông, vật liệu thép đến việc liên kết giữa các loại vật liệu này... phục vụ cho công tác nghiên cứu. SAP2000 là phần mềm đi theo hướng thứ nhất.
Với phần mềm SAP2000 khi tính toán công trình từ một phương án kiến trúc, phải đưa ra giải pháp kết cấu cho công trình, từ giải pháp kết cấu đó xây dựng sơ đồ tính cho công trình.
Sơ đồ tính của công trình là hình ảnh đơn giản hóa mà vẫn đảm bảo phản ánh sát với sự làm việc thực tế của công trình. Bởi vậy, trong sơ đồ tính người ta lược bỏ các yếu tố không cơ bản và chỉ xét đến các yếu tố chủ yếu quyết định khả năng làm việc của công trình và người tính phải biết lựa chọn sơ đồ tính.

Khi lựa chọn sơ đồ tính, những yếu tố cần quan tâm làm cơ sở cho quá trình chuyển đổi từ công trình thực sang sơ đồ tính là: 

· Cấu tạo của kết cấu và tầm quan trọng của nó .

· Khả năng tính toán của chương trình hay phương pháp tính sẽ sử dụng.

· Tải trọng và tính chất của tải trọng.

· Sơ đồ đã phản ánh được sự làm việc chính xác của công trình hay chưa .

· Có thể sử dụng một số giả thiết chấp nhận được để đơn giản  sơ đồ . 

Các bước cần thiết khi biến đổi từ một công trình thực về sơ đồ tính:

· Từ phương án kiến trúc đưa ra giải pháp kết cấu cho công trình (có điều chỉnh nếu kiến trúc không hợp lý).

· Từ giải pháp kết cấu đã có lựa chọn sơ đồ tính (ví dụ là khung phẳng hay khung không gian).
· Thay các cấu kiện của kết cấu thành các phần tử nối với nhau qua các nút. Tuỳ thuộc vào loại kết cấu mà phần tử có thể biểu diễn qua đường trục (với kết cấu hệ thanh ) hoặc biểu diễn bằng các mặt trung gian ( kết cấu tấm, vỏ .. ) 

· Thay các tiết diện bằng một số đại lượng đặc trưng như diện tích (A), mômen quán tính ( I )... hoặc các giá trị A, I tương đương.
· Thay các thiết bị tựa bằng các liên kết tựa lý tưởng (không ma sát) gọi là các  gối (gối cứng, gối đàn hồi). 

· Đưa tải trọng tác dụng trên bề mặt cấu kiện về các nút, trục hoặc các mặt trung gian.
· Bỏ qua một số yếu tố giữ vai trò thứ yếu (không cần thiết ) để đơn giản cho quá trình đưa về sơ đồ tính.
2.6 Đặt trưng vật liệu

Vật liệu có thể được khai báo bằng các thông số đặc trưng:

· Môđun đàn hồi (modulus of elasticity) E: dùng để xác định độ cứng dọc trục và độ cứng uốn.

· Môđun đàn hồi trượt (shear modulus) G: dùng để xác định độ cứng chống cắt và đọ cứng xoắn. G có thể được xác định thông qua E và μ:
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· Hệ số nở ngang (Poisson’s ratio) μ: là tỷ số giữa biến dạng ngang so với biến dạng dọc trục khi chịu kéo- nén dọc trục.

· Khối lượng riêng (mass density) ρ: dùng để xác định khối lượng của phần tử.

· Trọng lượng riêng (weight density) w: đùng để xác định trọng lượng của phần tử.

· Chỉ số thiết kế: để xác định loại thiết kế kết cấu(bê tông cốt thép, thép ,nhôm) hoặc loại vật liệu khác. Nếu vật liệu thuộc loại thiết kế là bê tông cốt thép thì chương trình sẽ tính toán lượng cốt thép cần thiết của tiết diện dựa vào cường độ bê tông, cường độ cốt thép theo tiêu chuẩn thiết kế bê tông dược sử dụng. Nếu vật liệu thuộc loại thiết kế là thép hoặc nhôm thì chương trình sẽ tìm loại tiết diện có diện tích nhỏ nhất trong số tiết diện được khai báo mà đảm bảo khả năng chịu lực dựa trên cường độ thép hoặc nhôm theo tiêu chuẩn thiết kế kết cấu thép hoặc nhôm.

Click menu Define → Materials → Add New Material
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Chú thích:

	STT
	TÊN TIẾNG ANH
	CHỨC NĂNG

	1
	Define Materials
	Định nghĩa vật liệu

	2
	Add New Material
	Tạo vật liệu mới

	3
	Add Copy of Material
	Thêm vật liệu mới giống vật liệu hiện hành

	4
	Modify/Show Material
	Hiệu chỉnh vật liệu hiện hành

	5
	Delete Material
	Xóa vật liệu 

	6
	Show Advanced Properties
	Hiển thị thuộc tính nâng cao vật liệu

	7
	Add Material Property
	Thêm thuộc tính vật liệu

	8
	Region
	Vùng (miền), Quốc gia sử dụng vật liệu

	9
	Material Type
	Loại vật liệu (concrete: bêtông, steel: thép,…)

	10
	Material Name and Display Color
	Tên vật liệu và hiển thị màu vật liệu

	11
	Materia Notes
	Ghi chú vật liệu

	12
	Weight per unit volume
	Trọng lượng riêng

	13
	Mass per unit volume
	Khối lượng riêng

	14
	Isotropic Property Data
	Dữ liệu thuộc tính vật liệu

	15
	Modulus of Elasticity, E
	Mô đun đàn hồi 

	16
	Possion’s Ratio
	Hệ số poát- xông

	17
	Coefficient of Thermal Expansion, A
	Hệ số giãn nở vì nhiệt

	18
	Shear Modulus, G
	Mô đun đàn hồi trượt

	19
	Other Properties for {Steel, Concrete, Materials
	Các thuộc tính khác của vật liệu

	20
	Specifield concrete compressive strength, f’c
	Cường độ bê tông


Ví dụ: Khai báo vật liệu bê tông B20, Thép AII
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2.7 Đặc trưng hình học

Click menu Define → Section Properties → Frame Section→ Add New Property
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2.7.1 Tiết diện chữ nhật
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Chọn Rectangular, xuất hiện hộp thoại
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	STT
	TÊN TIẾNG ANH
	CHỨC NĂNG

	1
	Section Name
	Tên tiết diện

	2
	Section Properties
	Những đặc trưng của tiết diện

	3
	Set Modifiers
	Hệ số nhân giá trị đặc trưng hình học

	4
	Materrial
	Loại vật liêu

	5
	Depth (t3)
	Chiều cao tiết diện

	6
	Width (t2)
	Bề rộng tiết diện

	7
	Concrete Reiforcement
	Những thông số dùng thiết kế thép 
cho vật liệu Bê tông cốt thép


2.7.2 Tiết diện hình tròn

Chọn Circular, xuất hiện hộp thoại
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	STT
	TÊN TIẾNG ANH
	CHỨC NĂNG

	1
	Section Name
	Tên tiết diện

	2
	Section Properties
	Những đặc trưng của tiết diện

	3
	Set Modifiers
	Hệ số nhân giá trị đặc trưng hình học

	4
	Materrial
	Loại vật liêu

	5
	Diameter (t3)
	Đường kính tiết diện

	6
	Concrete Reiforcement
	Những thông số dùng thiết kế thép 
cho vật liệu Bê tông cốt thép


2.7.3 Tiết diện chữ I 
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2.7.4 Các loại tiết diện và các thông số
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2.8 Phần tử hữu hạn dạng thanh phẳng và không gian

Các thành phần thực của công trình được mô hình bằng các đối tượng. Các đối tượng thường gồm các loại sau:

· Đối tượng điểm (Point object): thường sử dụng là nút (Joint), nút được tự động tạo ra tại các góc hoặc tại các đầu của các phần tử, liên kết chỉ có thể xuất hiện tại các nút.

· Đối tượng đường (Line object): thường sử dụng là thanh/ dây căng (Frame/cable), dùng để mô hình các cấu kiện như dầm, cột, giằng, dàn và dây căng.

· Đối tượng mặt (Area object): dùng để mô hình kết cấu tường, sàn cũng như các kết cấu khối có ứng suất phẳng hoặc biến dạng phẳng.
· Đối tượng khối (Solid object): dùng để mô hình kết cấu khối 3 chiều.
Theo quy tắc chung, hình dạng của đối tượng phải tương ứng với hình dạng thực của cấu kiện. 
2.9 Các dạng tải trọng (tĩnh tải; hoạt tải đứng; tải trọng gió tĩnh; tải trọng gió động; tải động đất)

Click menu Define → Load Patterns
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Define Load Patterns

Load Patters

Load Patter Name
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	STT
	TÊN TIẾNG ANH
	Ý NGHĨA

	1
	Load Name
	Tên trường hợp tải

	2
	Type
	Loại tải trọng


	3
	Self Weight Multiplier
	Hệ số nhân

	4
	Auto Lateral Load
	Tự động tính tải trọng theo
các tiêu chuẩn khác nhau

	5
	Add New Load
	Thêm tải mới

	6
	Modify Load
	Hiệu chỉnh tải trọng

	7
	Modify Lateral Load
	Hiệu chỉnh trường hợp tải
tính tự động

	8
	Delete Load
	Xóa tải được chọn

	9
	DEAD
	Tĩnh tải

	10
	LIVE
	Hoạt tải

	11
	QUAKE
	Tải động đất

	12
	WIND
	Tải gió

	13
	OTHER
	Tải khác

	14
	MOVING LOAD
	Tải di động

	15
	SNOW
	Tải tuyết

	16
	WAVE
	Tải sóng


Chú ý: Self Weight Multiplier là hệ số nhân trọng lượng bản thân. Khi người sử dụng khai báo hệ số này và hệ số Weight per unit Volume (Trọng lượng riêng) khác 0 thì chương trình sẽ tự động tính trọng lượng bản thân sau đó cộng với tải khác trong cùng trường hợp tải.
Nhập tĩnh tải:
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Thêm hoạt tải:
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Thêm tải gió:
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Thêm tải động đất:
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2.10 Tổ hợp tải trọng (Tổ hợp cơ bản, tổ hợp đặc biệt, tổ hợp bao)

Chương trình cho phép người sử dụng tổ hợp các trường hợp tải trọng mục đích nhằm tìm ra giá trị nội lực tại những vị trí nguy hiểm nhất của cấu kiện. Giúp cho người thiết kế chọn tiết diện và bố trí cốt thép một cách hợp lý nhất.

Click menu Define → Load Combinations 
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Chú thích:



Add New Combo: Thêm tổ hợp mới



Modify/Show Combo: Hiệu chỉnh tổ hợp



Delete Combo: Xóa tổ hợp được chọn

Chọn Add New Combo

[image: image88.png]" SAP2000+ETABS_BaiGiangDH_20151124.doc [Compatibility Mode] - Microsoft Sl X
pemeT] in nces  alngs jonal7 o
h S| N Lo [ S =1 at .
v14.2.2 Advanced - MAU 8 %
e B O mw A Amim bmy Dz Gwm i B
=N e e

G oo B D OORAO M 3y e Par & B

& Load Combination Data

Load Combination Name (liser Generated) TH1

Notes. Modiy/Shon Notes.

Load Combination Type. Linear Acd

Options Envelope
(Absolite Add

R3S
————{Rangedd
Define Combination of Load Case Resuls
Load Case Name. LosdCase Type _Scale Factor

HOATTAL [Grear Staic i
TINHTAL Crea Siati i

30 View _

X1009 Y1874 21200 [GL0BAL

100%

Words: 12708 | English (Uss)

[EEEE

Page: 37 of 1

»)





	STT
	TÊN TIẾNG ANH
	CHỨC NĂNG

	1
	Load Combination Name
	Tên tổ hợp tải trọng

	2
	Load Combination Type
	Kiểu tổ hợp

	3
	ADD (Linear Add)
	Cộng tác dụng (Kết quả nội lực của các 
trường hợp tải được cộng lại với nhau)

	4
	ENVE (Envelope)
	Biểu đồ bao ( Lấy kết quả nội lực của các
trường hợp để đưa ra giá trị Max và Min)

	5
	ABS (Absolute Add)
	Lấy giá trị tuyệt đối

	6
	SRSS
	Tổ hợp theo căn bậc hai tổng bình phương
các trường hợp tải

	7
	Case Name
	Tên trường hợp tải

	8
	Scale Factor
	Hệ số tổ hợp tải

	9
	Add
	Thêm trường hợp tải cho tổ hợp

	10
	Modify
	Hiệu chỉnh trường hợp tải

	11
	Delete
	Xóa trường hợp tải được chọn


Ví dụ:
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2.11 Điều kiện biên

2.11.1  Điều kiện biên là Gối, Khớp, Ngàm

Chọn những phần tử nút cần gán điều kiện biên

Click menu Assign → Joint → Restraints
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Chú thích:

Translation 1, 2, 3: Chuyển vị thẳng đứng theo phương trục 1, 2, 3

Rotation about 1, 2, 3: Chuyển vị xoay quanh trục 1, 2, 3
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: Liên kết ngàm
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: Liên kết gối cố định
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: Liên kết gối di động
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2.11.2  Điều kiện biên là gối đàn hồi (Springs) cho nút (Joint)

Chọn những phần tử nút cần gán điều kiện biên

Click menu Assign → Joint → Springs

Nhập giá trị độ cứng lò xo

2.11.3  Điều kiện biên là gối đàn hồi (Springs) cho thanh (Frame)

Chọn những phần tử thanh cần gán điều kiện biên

Click menu Assign → Frame → Line Springs

Nhập giá trị độ cứng lò xo

2.11.4  Điều kiện biên là gối đàn hồi (Springs) cho tấm (Area)

Chọn những phần tử tấm cần gán điều kiện biên

Click menu Assign → Area → Area Springs

Nhập giá trị độ cứng lò xo

2.11.5  Giải phóng liên kết (Releases)

Chọn những thanh cần giải phóng liên kết

Click menu Assign → Frame → Releases/Partial Fixity 

Chú thích:



Start: Giải phóng liên kết điểm đầu phần tử



End: Giải phóng liên kết điểm cuối phần tử



Axial Load: Giải phóng lực dọc trục



Shear Force 2, 3 (Major): Giải phóng lực cắt theo trục 2, 3



Torsion: Giải phóng mô men xoắn



Moment 22, 33 (Minor): Giải phóng mô men theo trục 22, 33



No Releases: Không giải phóng liên kết



Frame Partial Fixity Springs: Cho phép gắn lò xo vào vị trí giải phóng liên kết

2.11.6  Sàn tuyệt đối cứng

Qua mô hình tính toán người ta thấy được rằng độ cứng trong mặt phẳng của tổ hợp hệ dầm sàn rất lớn, biến dạng rất nhỏ so với biến dạng ngoài mặt phẳng. Do đó mô hình sàn tuyệt đối cứng (Diaphragm) được áp dụng dùng trong tính toán nhà cao tầng. Người sử dụng cần lưu ý nếu mô hình kết cấu có nhiều mặt phẳng thì gán sàn tuyệt đối cứng cần chọn từng mặt phẳng tương ứng và gán ràng buộc cho chúng.

Chọn các nút cần gán ràng buộc trong cùng một mặt phẳng cứng

Click menu Assign → Joint → Constraints → Diaphragm
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Chọn Add New Constraint →Z Axis →OK
2.12 Tính toán tổ hợp nội lực và tính toán cốt thép theo TCVN cho dầm và khung

2.12.1 Tính toán tổ hợp nội lực cho dầm

Sau đây trình bày hai cách tổ hợp nội lực và các trường hợp hoạt tải tương ứng. 

Cách 1: Cho hoạt tải tác dụng trên từng nhịp dầm

Lần lượt cho hoạt tải tác dụng trên từng nhịp dầm.

Tiến hành tổ hợp bằng cách tại mỗi tiết diện của dầm tính hai giá trị mô men:

 

Mk,max = MkG + (MkP+


Mk,min = MkG + (MkP-
trong đó: 

+ Mk,max; Mk,min: lần lượt là mômen uốn lớn nhất và nhỏ nhất tại tiết diện k;

+ MkG: mômen uốn tại tiết diện k do tĩnh tải gây ra;

+ MkP+: mômen uốn tại tiết diện k do những trường hợp hoạt tải gây ra mang dấu dương;

+ MkP-: mômen uốn tại tiết diện k do những trường hợp hoạt tải gây ra mang dấu âm.
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Hình 2.4. Các trường hợp tải trọng tác dụng lên dầm D1 (cách tổ hợp 1)
Tương tự với lực cắt:

Qk,max = QkG + (QkP+


Qk,min = QkG + (QkP-
trong đó: 

+ Qk,max; Qk,min: lần lượt là lực cắt lớn nhất và nhỏ nhất tại tiết diện k;

+ QkG: lực cắt tại tiết diện k do tĩnh tải gây ra;

+ QkP+: lực cắt tại tiết diện k do những trường hợp hoạt tải gây ra mang dấu dương;

+ QkP-: lực cắt tại tiết diện k do những trường hợp hoạt tải gây ra mang dấu âm.


Trong ví dụ đang xét, ta thiết lập sơ đồ tác dụng của tĩnh tải và các sơ đồ tác dụng của hoạt tải (mỗi sơ đồ hoạt tải tương ứng với hoạt tải tác dụng trên từng nhịp dầm). 

Trong chương trình SAP2000, sau khi đã thành lập xong các trường hợp tải trọng (TT, HT1, HT2, HT3, HT4) ta tiến hành định nghĩa các tổ hợp như sau:

HT1A = ENVE (HT1,0);

HT2A = ENVE (HT2,0);

HT3A = ENVE (HT3,0);

HT4A = ENVE (HT4,0);

BAO1 = ADD (TT, HT1A, HT2A, HT3A, HT4A)

Cách tổ hợp này có ưu điểm: phân tích tải trọng đơn giản, xác định tổ hợp nội lực chính xác đối với tất cả các tiết diện với cả mô men lẫn lực cắt.

Cách 2: Xét các trường hợp hoạt tải tác dụng gây nguy hiểm cho nhịp và gối

Mỗi một trường hợp hoạt tải sẽ gây nguy hiểm cho các tiết diện giữa nhịp hoặc gối tương ứng.

+ Hoạt tải gây nguy hiểm cho tiết diện giữa nhịp: hoạt tải được đặt cách nhịp.

+ Hoạt tải gây nguy hiểm cho tiết diện gối: hoạt tải được đặt ở hai bên gối đó và cách nhịp với những nhịp ở hai bên gối đó.

Tiến hành tổ hợp bằng cách tại mỗi tiết diện của dầm tính hai giá trị mô men:

Mk,max = MkG + max MkP
Mk,min = MkG + min MkP
trong đó: 

+ Mk,max; Mk,min: lần lượt là mômen uốn lớn nhất và nhỏ nhất tại tiết diện k;

+ MkG: mômen uốn tại tiết diện k do tĩnh tải gây ra;

+ max MkP, min MkP  -  giá trị mômen uốn lớn nhất và bé nhất tại tiết diện k (lấy với dấu đại số) trong các MkPi
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Hình 2.5. Các trường hợp tải trọng tác dụng lên dầm D1 (cách tổ hợp 2)
Tương tự tại mỗi tiết diện của dầm tính hai giá trị lực cắt:

Qk,max = QkG + max QkP
Qk,min = QkG + min QkP
trong đó: 

+ Qk,max; Qk,min: lần lượt là lực cắt lớn nhất và nhỏ nhất tại tiết diện k;

+ QkG: lực cắt tại tiết diện k do tĩnh tải gây ra;

+ max QkP, min QkP  -  giá trị lực cắt lớn nhất và bé nhất tại tiết diện k (lấy với dấu đại số) trong các QkPi

Trong ví dụ đang xét, ta thiết lập sơ đồ tác dụng của tĩnh tải và các trường hợp bất lợi của hoạt tải (mỗi sơ đồ hoạt tải sẽ gây nguy hiểm cho nhịp hoặc gối tương ứng):

         Trong chương trình SAP2000, sau khi đã thành lập xong các trường hợp tải trọng (TT, HT1, HT2, HT3, HT4, HT5) ta tiến hành định nghĩa các tổ hợp như sau:

COMB1 = ADD (TT, HT1);

COMB2 = ADD (TT, HT2);

COMB3 = ADD (TT, HT3);

COMB4 = ADD (TT, HT4);

COMB5 = ADD (TT, HT5);

BAO2 = ENVE (COMB1, COMB2, COMB3, COMB4, COMB5)

Cách này có ưu điểm là có thể xác định tổ hợp nào là nguy hiểm cho tiết diện đang xét, nhanh chóng cho kết quả nếu chỉ kiểm tra tại một tiết diện. Nhưng có nhược điểm là chỉ cho kết quả chính xác với mô men dương max tại nhịp và mô men âm min tại gối còn các giá trị mô men max hoặc min tại các tiết diện trung gian có thể chưa chính xác, đồng thời tổ hợp lực cắt xác định như trên cũng có thể không chính xác vì chưa xét hết tất cả các tổ hợp có khả năng xảy ra.
2.12.2 Tính toán tổ hợp nội lực cho khung

- Ở mỗi tiết diện quan trọng, phải tìm được các cặp nội lực nguy hiểm nhất, cụ thể như sau: 


+ Đối với các phần tử dầm: Mmax, Mmin, Qmax 
+ Đối với các phần tử cột:
Mmax và Ntư
Mmin và Ntư
Nmax và Mtư
Riêng đối với tiết diện chân cột tầng 1, ngoài Ntư còn phải tính thêm Qtư để phục vụ cho việc tính móng.

Với nhà khung BTCT ít tầng, đã thiết lập 5 trường hợp tác dụng của tải trọng: 

+ Tĩnh tải (TT)

+ Hoạt tải đứng 1 (HT1)

+ Hoạt tải đứng 2 (HT2)

+ Gió trái (GT)

+ Gió phải (GP)

thì ta có thể lập các tổ hợp như sau:

TH1: TT + HT1 (hệ số tổ hợp tương ứng: 1/1)

TH2: TT + HT2 (1/1)

TH3: TT + GT (1/1)

TH4: TT + GP (1/1)

TH5: TT + HT1 + HT2 (1/0,9/0,9)

TH6: TT + HT1 + GT (1/0,9/0,9)

TH7: TT + HT1 + GP (1/0,9/0,9)

TH8: TT + HT2 + GT (1/0,9/0,9)

TH9: TT + HT2 + GP (1/0,9/0,9)

TH10: TT + HT1 + HT2 + GT (1/0,9/0,9/0,9)

TH11: TT + HT1 + HT2 + GP (1/0,9/0,9/0,9)
2.12.3 Tính toán cốt thép

- Đối với dầm (xà ngang) tính như cấu kiện chịu uốn.

- Đối với cột, xà nghiêng với độ dốc lớn: tính như cấu kiện chịu nén lệch tâm.


- Đối với cột tính theo cấu kiện chịu nén lệch tâm đặt cốt thép đối xứng. Chọn các cặp nội lực sau để tính toán:



 Mmax+ và Ntư ; Mmin- và Ntư ; Nmax và Mtư

Riêng tại chân cột tổ hợp thêm Qtư để tính móng.

Các bước nhập số liệu SAP2000 để tính cốt thép theo tiêu chuẩn Việt Nam
a) Chọn tiêu chuẩn thiết kế Bê tông cốt thép: Do Sap2000 không có TCVN, nên dùng tiêu chuẩn gần giống nhất là Tiêu chuẩn Canada.
Vào Menu Options → Preferences → Concrete Frame Design đổi Design Code thành CSA-A23.3.94.
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b) Khai báo cường độ vật liệu bê tông và cốt thép:
Vào Menu Define → Materials chọn CONC → Modify/Show Material..
Nhập giá trị cường độ bê tông  f’c theo bảng 1 tùy thuộc vào loại bê tông, giá trị  fy theo bảng 2 tùy thuộc vào loại thép. Ví dụ dùng bê tông B20 thì nhập f’c=224.4 kG/cm2 = 2244T/m2, cốt thép loại AII thì nhập fy=fys= 3176.47kG/cm2 = 31764.7T/m2.
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Bảng 1: giá trị f’c tương ứng với cấp độ bền bê tông theo TCVN

	Cấp độ bền Bê tông, B
	10
	15
	20
	22,5
	25
	30
	40
	45

	Rn (kG/cm2)
	65
	90
	110
	130
	155
	170
	215
	250

	f’c  (kG/cm2)
	130.39
	182.22
	224.40
	267.26
	321.85
	355.16
	457.85
	540.81




Bảng 2: giá trị fy tương ứng với loại cốt thép theo TCVN
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c) Khai báo cách bố trí cốt thép trong tiết diện:

Nguyên tắc chung: 

- Dầm tính theo cấu kiện chịu uốn

- Cột tính theo cấu kiện chịu nén lệch tâm xiên ( chịu lực dọc và moment uốn theo cả 2 phương), do tính chất của bài toán tính thép cột khác với dầm nên đối với tiết diện cột cần phải khai báo số lượng các thanh thép trên mỗi biên của cột. 

Dù Dầm và Cột có cùng 1 kích thước tiết diện vẫn phải khai báo là 2 loại tiết diện riêng biệt. Ví dụ trong khung: cột có kích thước 200x300, dầm cũng có kích thước 200x300 thì phải khai báo 2 loại tiết diện COT20x30 và DAM20x30 để gán cho thanh cột và thanh dầm.

 Vào Menu Define → Frame Sections → Chọn Add Rectangular nếu muốn khai báo tiết diện mới hoặc chọn loại tiết diện đã khai báo rồi chọn Modify/ Show Property để sửa.
· Đối với Dầm:
[image: image106.png]Crrr— T

Desn Tomp.ogi tidt dién Cothay Dim
s et € conn ® Bean
e | [ ot vt s i
S - Khoang cich tir méf
St T bt tomg dén trong sk
poy ps 7 st thép for
w21 Fz B 1 .
. Rerfocanent Oyt o Ducl Boans
Lot A
: ; : w g
o [ Boen [0 °
Comm > | ChnbsmTmlisan
- Khai bdo khodng cich tir mép tidt
e dign dén trong tim cdt thép cua cot
thép trén va cot thép dudi.
Nhu trén 1a khai bdo khodng cdch d6 14
4em = 0,04m
=]





· Đối với Cột:
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d) Khai báo tổ hợp nội lực sử dụng để tính cốt thép:

Vào menu Design → Concrete Frame Desgin → Select Design Combo

e) Khai báo hệ số điều chỉnh:

Do dùng tiêu chuẩn Canada nên cần phải điều chỉnh để phù hợp với tiêu chuẩn Việt Nam. Ở đây cần điều chỉnh trong các thanh cột, còn cốt thép dầm tính theo tiêu chuẩn Canada hoàn toàn khớp với tiêu chuẩn Việt Nam.
Chọn tất cả các tiết diện cột, vào menu Design → Concrete Frame Design → View/ Resive Overwrite.

Nhập K =0,69 ( cho cả 2 phương Major và Minor)
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Nhớ sau khi nhập lệnh xong thì cần hủy chọn các thanh cột.
f) Tính nội lực và tính cốt thép:

Tính nội lực như bình thường, chọn Run now.
Sau khi có nội lực tính cốt thép, vào Menu Design →  Concrete Frame Design → Start Design / Check of Structure. Trên màn hình sẽ hiển thị diện tích cốt dọc trong hệ.

· Đối với dầm: sẽ thể hiện cốt thép trên và dưới
· Đối với cột sẽ thể hiện tổng lượng thép, căn cứ vào số thanh thép đã khai báo ở phần Frame Section mà chọn ϕ cho phù phợp yêu cầu.

Sau này bất cứ lúc nào ta cũng có thể xem lại được diện tích cốt thép bằng lệnh: Menu Design →  Concrete Frame Design → Display Design info.

Chú ý nên đổi sang đơn vị kgf-cm-C để cốt thép thể hiện cho dễ đọc
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*Chú ý: Hệ số điều chỉnh K = 0,69 ở trên là hệ số trung bình, nếu tính chính xác thì sau khi tính được cốt thép trong cột thì tính lại hàm lượng và điều chỉnh lại hệ số K như bảng sau ( việc làm này khá mất thời gian do mỗi cột có mỗi μ khác nhau nên sẽ có mỗi K khác nhau, do đó phai nhập K cho từng thanh cột).
[image: image111.png]Mic bé tong

150 | 200 | 250 | 300 | 350 [ 400 [ 500 | 600
Ham lugng 1

1.0% 073 | 075 | 077 | 079 | 080 | 0.81 | 0.82 | 083
15% 064 | 067 | 069 | 071 | 072 | 073 | 075 | 076
2.0% 058 | 061 | 063 | 0.65 | 0.66 | 0.68 | 0.69 | 071
25% 054 | 056 | 059 | 0.60 | 0.62 | 0.63 | 0.65 | 0.66
3.0% 050 | 053 | 055 | 057 | 038 | 0.59 | 0.61 | 0.62
3.5% 047 | 050 | 052 | 053 | 055 | 0.56 | 0.58 | 059
4.0% 045 | 047 | 049 | 051 | 052 | 053 | 055 | 036
45% 043 | 045 | 047 | 049 | 050 | 051 | 053 | 054
5.0% 041 | 043 | 046 | 047 | 048 | 049 | 051 | 02
5.5% 039 | 041 | 043 | 045 | 046 | 047 | 049 | 00
6.0% 038 | 040 | 042 | 043 | 044 | 046 | 047 | 048





CHƯƠNG 3. TRÌNH TỰ NHẬP SỐ LIỆU VÀ PHÂN TÍCH MỘT SỐ BÀI TOÁN TRÊN PHẦN MỀM SAP2000

3.1 GIỚI THIỆU CHUNG
Cùng với xu hướng ngày càng phát triễn của khoa học và công nghệ
trong lĩnh vực Xây dựng, quá trình tự động hóa tính toán và thiết kế với sự hỗ
trợ của máy tính bằng các phần mềm chuyên dụng đã được triễn khai áp
dụng rộng rãi ở nước ta.

Trong những năm 1980 trở lại đây, công nghệ máy tính đã có những
bước phát triễn mạnh mẽ, nó góp phần thúc đẩy nghiên cứu và phát triển
công nghệ trên thế giới trong hầu hết các lĩnh vực khoa học kĩ thuật. Trong
lĩnh vực xây dựng, công nghệ máy tính cũng đã được ứng dụng rộng rãi, bao
gồm các phần mềm về quản lí xây dựng, kinh tế xây dựng, phân tích nội lực
kết cấu, thiết kế kết cấu thép và kết cấu bê tông cốt thép, thiết kế và thể
hiện bản vẽ kỹ thuật ...

Theo xu hướng hội nhập, các phần mềm tính toán, quản lí thuộc chuyên
ngành xây dựng đã được du nhập từ nước ngoài và được ứng dụng khá rộng
rãi bên cạnh sự phát triển của hệ thống phần mềm trong nước. Tuy nhiên,
các phần mềm nước ngoài có nhiều vấn đề chưa tương thích với tiêu chuẩn
Việt Nam nên một số chỉ tồn tại trong giới hạn tham khảo hoặc chưa khai
thác hết khả năng tự động hóa của chương trình.

Các phần mềm trong nước đang phát triển khá mạnh mẽ và rộng rãi
nhưng vẫn còn một số bất lợi đó là chưa có sự thống nhất trong hướng phát
triển, các phần mềm đa phần tự phát, khả năng ứng dụng thực tế của các
chương trình vẫn còn hạn hẹp, chưa có sự đánh giá hay thẩm định của cơ
quản thẩm quyền cũng như chưa có chính sách bảo hộ phần mềm thỏa đáng.

Ngày nay, các chương trình phân tích nội lực và thiết kế kết cấu đã có
những bước tiến vượt bậc và rất phong phú về số lượng, rất mạnh trong quá
trình tính toán chẳng hạn như: phần mềm ANSYS, STAAD Pro, SAP2000,
ETABS, SAMCEF, STRAND, PLAXIS ... đã có thể giải quyết được hầu hết
các vấn đề trong thiết kế xây dựng. Trong đó SAP2000 là phần mềm được ưa
chuộng và sử dụng rộng rãi nhất do có nhiều tính năng ưu việt hơn các phần
mềm khác.

Phiên bản đầu tiên của chương trình được mang tên SAP (Structural
Analysis Program) vào năm 1970, các phiên bản kế thừa tiếp theo sau là
SAP3, SAP IV và SAP 80 là phiên bản có tính thương mại đầu tiên của họ
phần mềm SAP, phần mềm này được phát triễn bởi công ty Computer and
Structure Inc (CSI). Năm 1992 CSI cho ra đời phiên bản tiếp theo là SAP90.
Tuy nhiên, phiên bản SAP2000 ra đời mới là bước phát triễn đột phá của họ
phần mềm SAP, theo như lời tuyên bố của hãng CSI thì SAP2000 là công
nghệ ngày nay cho tương lai! SAP2000 đã tích hợp các tính năng phân tích
kết cấu và tính năng thiết kế kết cấu thành một. Các phiên bản thông dụng
của SAP2000 là version 6.11, ver 7.42, ver 8.23 … và phiên bản mới đang được
sử dụng khá rộng rãi là SAP2000 version 14.2. Hiện nay, trên thị trường đã
có phiên bản SAP2000 version 17.
Tất cả các chương trình SAP2000 đều có đầy đủ các tính năng thiết kế kết cấu thép và bê tông cốt thép, các modul này được tích hợp cùng với các modul dùng để tạo và phân tích mô hình trong cùng một giao diện. SAP2000 version 17 hỗ trợ thiết kế kết cấu khung (frame elements) theo các tiêu chuẩn mới của Mỹ và Châu Âu như:
- Tiêu chuẩn thiết kế kết cấu bê tông cốt thép:

+ ACI 318-05 (2005) and IBC2003 (2003): Tiêu chuẩn Hoa Kỳ;

+ Canadian CSA-A23.3-94 (1994): Tiêu chuẩn của Canada;

+ British BS 8110-97 (1997): Tiêu chuẩn của Anh quốc
+ Eurocode 2-2004: Tiêu chuẩn châu Âu;

…

- Tiêu chuẩn thiết kế kết cấu thép:

+ AISC360-05 (2005) and IBC2006 (2006): Tiêu chuẩn Hoa Kỳ;

+ CAN/CSA-S16-01 (2001): Tiêu chuẩn của Canada;

+ BS5950 (2000): Tiêu chuẩn của Anh quốc;

+ Eurocode 3-2005: Tiêu chuẩn châu Âu;
…
3.2 TRÌNH TỰ NHẬP DỮ LIỆU

3.2.1 Sơ đồ tính kết cấu

a. Tạo sơ đồ tính kết cấu từ lưới

Menu File → New Model  (hoặc Ctrl + N) → xuất hiện hộp thoại  → chọn Grid Only
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Chọn một trong hai tọa độ, với công trình có các góc vuông thường sử dụng hệ tọa độ Cartesian khi đó phải định nghĩa các thong số sau:

- Number of Grid Line: Tổng số lưới theo các phương (X,Y,Z) thông thường ta dựa vào các trục kết cấu để định nghĩa lưới;

- Grid Spacing: Khoảng cách của lưới theo các phương (X,Y,Z);

- First Grid Line Location: Vị trí của lưới đầu tiên
b. Tạo sơ đồ tính kết cấu từ thư viện

b.1 Sơ đồ dầm (Beam):

- Menu File → New Model  (hoặc Ctrl + N)→ xuất hiện hộp thoại → chọn Beam:
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- Khai báo nhịp và chiều dài nhịp:
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- Sửa chiều dài nhịp:

Trong hộp thoại trên, kích chọn mục Use Custom Grid Spacing and Locate Origin (như hình dưới)
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Kích vào Edit Grid → xuất hiện hộp thoại:
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b.2 Tạo sơ đồ khung phẳng (2D Frame):

- Menu File→ New Model  (hoặc Ctrl + N)→ xuất hiện hộp thoại→ chọn 2D Frame:
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- Khai báo số tầng, số nhịp, chiều cao tầng, chiều dài nhịp:
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- Sửa kích thước:

Trong hộp thoại trên, kích chọn mục Use Custom Grid Spacing and Locate Origin (như hình dưới)
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Kích vào Edit Grid xuất hiện:
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b.3 Tạo sơ đồ khung không gian (3D Frames):
- Menu File → New Model  (hoặc Ctrl + N)→ xuất hiện hộp thoại → chọn 3D Frames:
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Xuất hiện hộp thoại:
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- Sửa kích thước:

Trong hộp thoại trên, kích chọn mục Use Custom Grid Spacing and Locate Origin (như hình dưới)
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Kích vào Edit Grid xuất hiện hộp thoại và sửa tương tự như phần khung phẳng.
3.2.2 Nhập đặc trưng vật liệu
a. Vật liệu bê tông cốt thép (CONC):

Vào Define → Materials → xuất hiện hộp thoại:
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Trong đó:
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b. Vật liệu thép (STEEL):

Vào Define → Materials → xuất hiện hộp thoại:
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3.2.3 Nhập đặc trưng tiết diện
1.2.3.1. Tiết diện cột (Column):

a. Cột vuông, cột chữ nhật:
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b. Cột tròn:
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1.2.3.2. Tiết diện dầm (Beam):
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1.2.3.3. Gán tiết diện:

  
Chọn những thanh có tiết diện giống nhau → Vào Assign → Frame → Frame  Sections xuất hiện hộp thoại sau:
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Chọn tên tiết diện cần gán → OK

3.2.4 Nhập phần tử đặc biệt
1.2.4.1. Giải phóng liên kết:

Thông thường liên kết giữa thanh với thanh là nút cứng, nếu muốn liên kết khớp thì ta loại bỏ mô men của thanh tại nút đó:

 
Chọn thanh → vào Asign → Frame → Releases/Partial Fixity.. → xuất hiện hộp thoại:
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Ví dụ: xem kết quả sau khi giải phóng liên kết thanh số 16 (vì kèo thép):

[image: image142.png]



1.2.4.2. Ràng buộc – thường sử dụng liên kết Cứng (Body)

Có thể sử dụng trong trường hợp sau:

[image: image143.emf]


Ví dụ: sau khi vẽ sơ đồ, tại vị trí liên kết tách ra làm 2 nút là 20 và 22 như sau:
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Chọn nút số 20 và 22 → vào Assign → Joint → Constrains → xuất hiện hộp thoại:
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3.2.5 Khai báo điều kiện biên
Chọn nút → vào Assign → Joint → Restraints… hoặc chọn:
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Xuất hiện hộp thoại – chọn kiểu liên kết:
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3.2.6 Nhập tải trọng và chuyển vị cưỡng bức ở gối tựa
a. Tĩnh tải (DEAD)

Vào menu Define → Load Patterns.. → Xuất hiện hộp thoại:
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Vào Load Pattern Name nhập “TT” → Self Weight Multiplier nhập “1.1” → Modify Load Pattern
b. Hoạt tải (LIVE)
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Vào Load Pattern Name nhập “HT1” → Type chọn “LIVE” → Self Weight Multiplier nhập “0” → Add New Load Pattern
c. Tải trọng gió tĩnh (WIND)
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Vào Load Pattern Name nhập “GT” → Type chọn “WIND” → Self Weight Multiplier nhập “0” → Add New Load Pattern
d. Tải trọng gió động (WIND) (thường dùng cho khung không gian)
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Vào Load Pattern Name nhập “GX” → Type chọn “WIND” → Self Weight Multiplier nhập “0” → Add New Load Pattern
e. Tải trọng động đất (QUAKE)
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Vào Load Pattern Name nhập “DDX” → Type chọn “QUAKE” → Self Weight Multiplier nhập “0” → Add New Load Pattern
f. Gán tải trọng cho kết cấu

- Tải trọng tập trung tại nút:

Chọn những nút có tải tập trung giống nhau → vào Assign → Joint Loads → Forces… → Xuất hiện hộp thoại:
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- Tải trọng tập trung trên thanh:

Chọn những thanh có tải tập trung giống nhau → vào Assign → Frame Loads → Point… → Xuất hiện hộp thoại:
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- Tải trọng phân bố đều trên thanh:

Chọn những thanh có tải phân bố đều giống nhau → vào Assign → Frame Loads → Distributed… → Xuất hiện hộp thoại:
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- Tải trọng phân bố không đều trên thanh:

Chọn những thanh có tải phân bố đều giống nhau → vào Assign → Frame Loads → Distributed… → Xuất hiện hộp thoại:
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- Xem tải trọng đã nhập:

Vào Display → Show Load Assigns→ Frame/Cable/Tendon.. xuất hiện hộp thoại:
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3.2.7 Tổ hợp tải trọng


Trong Sap2000 có 4 loại tổ hợp :



(1) Loại ADD
: Cộng đại số .



(2) Loại ENVE 
: Lấy giá trị bao.



(3) Loại ABS
: Cộng theo giá trị tuyệt đối.



(4) Loại SRSS
: Lấy căn bậc hai của tổng các bình phương.



Thường sử dụng 2 loại tổ hợp (1) và (2).

1.2.7.1. Tổ hợp cơ bản
Vào menu Define → Load Combinations.. → Xuất hiện hộp thoại:
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Kích vào Add New Combo… → Xuất hiện hộp thoại:
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1.2.7.2. Tổ hợp đặc biệt

Kích vào Add New Combo… → Xuất hiện hộp thoại:
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1.2.7.3. Tổ hợp bao

Kích vào Add New Combo… → Xuất hiện hộp thoại:
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3.2.8 Nhập số liệu thiết kế:

1.2.8.1. Chọn tiêu chuẩn thiết kế:

Vào Design → Concrete Frame Design → View/Revise Preferences… Xuất hiện hộp thoại:
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Trong hộp thoại này kích vào Design code: chọn CSA-A23.2.94 → OK
1.2.8.2. Chọn những tổ hợp nội lực được đưa vào thiết kế:

Vào Design → Concrete Frame Design → Select Design Combos… Xuất hiện hộp thoại:
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3.3 PHÂN TÍCH TÍNH TOÁN
3.3.1 Khai báo số mặt cắt thanh:

Chọn thanh → vào Assign → Frame → Output Stations… 
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Chú ý: Khai báo mặt cắt trên thanh của cột và dầm riêng biệt.

3.3.2 Khai báo bậc tự do:

Vào Analyze ( Set Analysis Options ...  → Xuất hiện hộp thoại:
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3.3.3 Tính toán nội lực:

Vào Analyze ( Run Analysis  hoặc nhấn (F5)
[image: image167.png]Clck
Case Name Tope

T Linear Stalic
MODAL Modal Show Case.
HT Linear Stalic —
H12 Linear Stalic Delete Resull for Case
a1 Linear Stalic —
P Linear Stalic

Fun/Da Not Fun Case

Run/Da Not Fun Al
Delete All Results

Show Load Case Tree.

~Anabss Morior Optons
 iways Show
© Never Shan
@ Showhfter [4 seconds





3.4 XEM KẾT QUẢ VÀ XUẤT THÀNH FILE
3.4.1 Kết quả nội lực thanh:
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3.4.2 Kết quả phản lực tại gối: 
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3.4.3 Xuất thành File

Vào File → Export → Sap2000 MS Excel Spreadsheet.xls File… 
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Xuất hiện hộp thoại:
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3.5 THỰC HÀNH 1: THIẾT KẾ DẦM LIÊN TỤC

Số liệu :

a. Tải trọng tác dụng vào dầm gồm có :


* Tĩnh tải : (đã kể đến trọng lượng bản thân của dầm)
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(Số liệu bên dưới là kích thước tiết diện dầm : hình chữ nhật b x h)


* Hoạt tải :
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b. Yêu cầu :


- Xác định nội lực trong hệ khi chịu các trường hợp tải trọng (cần phân tích hoạt tải thành các trường hợp để tổ hợp nội lực).


- Tổ hợp nội lực và vẽ biểu đồ bao nội lực.

Các bước tiến hành :

3.5.2 Phân tích hoạt tải thành các trường hợp tác dụng riêng lẻ trên từng nhịp :


Do tính chất của hoạt tải là có thể thay đổi nên cần phân tích hoạt tải thành các trường hợp riêng lẻ, mỗi trường hợp hoạt tải chỉ tác dụng trên một nhịp, sau đó sẽ tiến hành tổ hợp để xác định giá trị lớn nhất và nhỏ nhất của nội lực (hoặc phản lực) do hoạt tải gây ra trên hệ.


Từ số liệu hoạt tải đã cho ta phân tích được 5 trường hợp hoạt tải như sau:


* Hoạt tải 1 :
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* Hoạt tải 2 :
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* Hoạt tải 3 :
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* Hoạt tải 4 :
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* Hoạt tải 5 :
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3.5.3 Lập sơ đồ hình học :

- Khởi động chương trình Sap2000.
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- Chọn hệ đơn vị kN - m - oC :  

- Vào Menu File ( chọn lệnh New Model
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Chọn hệ dầm liên tục.

- Khai báo số nhịp dầm và chiều dài các nhịp :


Lúc ban đầu dầm sẽ có chiều dài các nhịp là như nhau, sau này ta sẽ hiệu chỉnh chiều dài của từng nhịp cho đúng số liệu thực tế.


Phần console ta cũng khai báo như 1 nhịp, sau này ta chỉ việc bỏ đi gối tựa ở đầu là sẽ được đoạn console.


Như vậy lúc đầu ta khai báo hệ dầm sẽ có 5 nhịp, chiều dài mỗi nhịp sẽ khai báo cụ thể trong mục Edit Grid…
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Trong phần Edit Grid… ta chọn kiểu Spacing để nhập khoảng cách các ô lưới
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- Ta được hệ dầm như hình sau :
[image: image186.png]%%
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Trên màn hình có 2 cửa sổ để xem hệ dưới 2 góc nhìn khác nhau : theo hình chiếu 3D (không gian) và theo hình chiếu 2D (mặt phẳng XY hoặc XZ hoặc YZ).


Ta có thể vào menu Options ( Windows để chọn số lượng cửa sổ trên màn hình để xem hệ theo các góc độ khác nhau (1, 2, 3, hoặc 4 cửa sổ được thể hiện trên màn hình). Đối với hệ phẳng, để nhìn hệ cho được rõ ta nên chỉ chọn số cửa sổ bằng 1, và chọn góc nhìn là hình chiếu 2D - mặt phẳng XZ.



Các nút lệnh chọn góc nhìn 


- Khai báo liên kết gối :


Các gối trong hệ như trên chưa đúng với bài toán đặt ra :


* Cần thay liên kết gối đầu phải console và bằng nút tự do.


Để thay liên kết gối tại 1 nút hoặc 1 số nút trong hệ cần chọn nút đó hoặc các nút bằng cách rê chuột xung quanh các nút muốn chọn, vào menu Assign ( Joint  ( Restraints hoặc bấm vào biểu tượng 
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Sau khi chọn nút và vào menu Assign ( Joint  ( Restraints sẽ xuất hiện hộp thoại cho phép khai báo liên kết gối (hoặc bỏ liên kết gối)
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Như trên, ta chọn các nút tại trục F vào menu Assign ( Joint  ( Restraints, chọn [image: image189.png]


 ( chọn [image: image190.png]


 để hoàn thành.


Hệ sẽ có dạng :

[image: image191.png]




Như vậy chúng ta đã tạo xong 1 sơ đồ tính theo yêu cầu.
3.5.4 Khai báo các thuộc tính của hệ (vật liệu, tiết diện, tải trọng):

Khai báo đặc trưng vật liệu: vào menu Define ( Materials ...
Ở đây tĩnh tải đã kể đến trọng lượng bản thân của dầm nên ở đây khi xác định nội lực chúng ta không cần phải khai báo đặc trưng vật liệu của hệ.

Khai báo hình dạng và kích thước tiết diện :


Theo bài: hệ dầm có 1 loại tiết diện có tiết diện hình chữ nhật b = 0,2m ; h = 0,35m.


Để khai báo các loại tiết diện trong hệ : vào menu Define ( Sections Properties( Frame Sections…
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Xuất hiện hộp thoại tiếp theo:Muốn chọn tiết diện CN bấm vào menu trải xuống chọn Concrete. 
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Sau đó chọn Rectangular
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Khai báo các thông số kích thước tiết diện :
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Ta khai báo mới 2 loại tiết diện :


+ Loại tiết diện hình chữ nhật 0,2 x 0,35 m sẽ có các thông số :


* Tên :
D200x350




* Vật liệu :
4000Psi

* Chiều cao :   
0,35




* Chiều rộng :
0,2


Bấm [image: image196.png]


 để chấp nhận các loại tiết diện vừa khai báo mới.


Sau khi khai báo trên hộp thoại Frame Properties sẽ xuất hiện TD D200x350
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Khai báo các trường hợp tải trọng :

Để phục vụ việc tổ hợp nội lực trong dầm ta cần phân tích Hoạt tải thành 6 trường hợp như đã trình bày ở phần trên (HT1, ..., HT6) và trường hợp Tĩnh tải.

Như đã trình bày, tải trọng của phần Tĩnh tải đã tính đến trọng lượng bản thân của hệ, nên ở đây ta không khai báo trọng lượng bản thân của hệ nữa.


Để khai báo các trường hợp tải trọng : vào menu Define ( Load Patterns ...
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+ Đối với trường hợp Tĩnh tải : 


* Tên : 
TinhTai


* Loại : 
DEAD
* Hệ số TLBT : 0


Sau khi sửa giá trị ( chọn Modify Load


+ Đối với trường hợp Hoạt tải 1,2,3,4,5,6 : 


* Tên : HT1 (hoặc 2,3,4,5)

* Loại : 
LIVE
* Hệ số TLBT : 0


Sau khi sửa giá trị ( chọn Add New Load.
Ở đây cần lưu ý do tĩnh tải của dầm đã được kể đến nên khi khai báo chúng ta phải để hệ số Selt Weight Multiplier = 0. Khi tải trọng không kể đến TLBT của dầm khi đó hệ số này sẽ khác 0 .

Kết quả bảng các trường hợp tải trọng như hình sau :
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Khai báo các trường hợp phân tích :


Bài toán bình thường nếu không xét dao động thì mỗi trường hợp phân tích sẽ tương ứng với một trường hợp tải trọng và nên xoá trường hợp phân tích động (MODAL) để khi tính toán được nhanh hơn. 
Vào menu Define ( Load Cases
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Khai báo tổ hợp tải trọng (tổ hợp nội lực) :


Trong Sap2000 có 4 loại tổ hợp :


(1) Loại ADD
: Cộng đại số .


(2) Loại ENVE 
: Lấy giá trị bao.


(3) Loại ABS
: Cộng theo giá trị tuyệt đối.


(4) Loại SRSS
: Lấy căn bậc hai của tổng các bình phương.


Thường sử dụng 2 loại tổ hợp (1) và (2).


Để khai báo các tổ hợp tải trọng : vào menu Define ( Load Combinations ...
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Chọn [image: image202.png]Add New Combo
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Để khai báo tổ hợp HTBD1 là tổ hợp kiểu ENVE của HT1 và 0*TT :


* Đặt tên tổ hợp : 
HTBD1;


* Chọn kiểu tổ hợp : Envelope;


* Chọn thành phần : TinhTai (hoặc DEAD);  Sửa hệ số nhân : 0( bấm nút [image: image204.png]Add





* Chọn thành phần : HT1;  

 
Sửa hệ số nhân : 1( bấm nút [image: image205.png]Add
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 để chấp nhận


 Tiếp tục chọn [image: image208.png]‘Add Copy of Combo.



 để thêm vào các tổ hợp HTBD2, HTBD3, HTBD4, HTBD5, HTBD6, cách tiến hành tương tự nhưng thay thành phần HT1 bằng thành phần hoạt tải tương ứng (HT2; HT3; HT4; HT5; HT6(chọn [image: image209.png]


 ).


Chọn [image: image210.png]Add New Combo



 để thêm tổ hợp BAO 


* Đặt tên tổ hợp : 
BAO;


* Chọn kiểu tổ hợp : Linear Add;


* Chọn thành phần : TinhTai (hoặc DEAD)
 Hệ số nhân : 1( bấm nút [image: image211.png]Add





* Chọn thành phần : HTBD1 ;  


 Hệ số nhân : 1( bấm nút [image: image212.png]Add





* Chọn thành phần : HTBD5 ;  


 Hệ số nhân : 1( bấm nút [image: image213.png]Add
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 để chấp nhận
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Chọn [image: image217.png]


 để chấp nhận.

3.5.5 Gán các đặc trưng cho các phần tử  trong hệ :


Nguyên tắc chung: cần chọn đối tượng trước rồi mới thực hiện lệnh gán.


Chọn các đối tượng bằng cách bấm chuột trực tiếp vào đối tượng hoặc rê chuột bao quanh đối tượng đó.


Gán tiết diện cho các thanh trong hệ :


* Chọn các thanh dầm nhịp A-B-C-D-E-F
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* Thực hiện lệnh gán vào menu Assign(Frame(Frame Sections… hoặc bấm vào biểu tượng 
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3.5.6 Gán tải trọng cho các phần tử  trong hệ :
Tải trọng phân bố trên thanh đều :

Chọn thanh, vào menu Assign ( Frame Loads ( Distributed ... hoặc bấm vào biểu tượng [image: image220.png]
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Áp dụng gán tải trọng cho các trường hợp trong hệ :


* Tĩnh tải :


- Lực phân bố đều:

+ Chọn thanh nhịp AB và BC , vào menu Assign ( Frame Loads ( Distributed ... , chọn Load Pattern Name là TinhTai, chọn Direction là Gravity, đặt giá trị Uniform Load = 10,2.

+ Chọn thanh nhịp BC và DE, vào menu Assign ( Frame Loads ( Distributed ..., (chọn Load Pattern Name là TinhTai, chọn Direction là Gravity), đặt giá trị Uniform Load = 12.

+ Chọn thanh nhịp EF, vào menu Assign ( Frame Loads ( Distributed ..., (chọn Load Pattern Name là TinhTai, chọn Direction là Gravity), đặt giá trị Uniform Load = 3.
* Hoạt tải 1:


- Lực phân bố đều:

+ Chọn thanh nhịp AB, vào menu Assign ( Frame Loads ( Distributed ..., chọn Load Pattern Name là HT1, (chọn Direction là Gravity), đặt giá trị Uniform Load = 7,5.
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* Hoạt tải 2:

- Lực phân bố đều:

+ Chọn thanh nhịp BC, vào menu Assign ( Frame Loads ( Distributed ..., chọn Load Pattern Name là HT2, (chọn Direction là Gravity), đặt giá trị Uniform Load = 7,5.
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* Hoạt tải 3:


- Lực phân bố đều:

+ Chọn thanh nhịp CD, vào menu Assign ( Frame Loads ( Distributed ..., chọn Load Pattern Name là HT3, (chọn Direction là Gravity), đặt giá trị Uniform Load = 8,5.
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* Hoạt tải 4:


- Lực phân bố đều:

+ Chọn thanh nhịp DE, vào menu Assign ( Frame Loads ( Distributed ..., chọn Load Pattern Name là HT4, (chọn Direction là Gravity), đặt giá trị Uniform Load = 8,5.
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* Hoạt tải 5:


- Lực phân bố đều:

+ Chọn thanh đầu nhịp EF, vào menu Assign ( Frame Loads ( Distributed ..., chọn Load Pattern Name là HT5, (chọn Direction là Gravity), đặt giá trị Uniform Load = 2.
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Lưu ý: do trên màn hình chỉ hiển thị 1 loại tải trọng, nên sau khi khai báo tải trọng phân bố thì trên màn hình hiển thị tải phân bố thì sẽ không "thấy" các lực tập trung tại nút. Điều này là bình thường.

Nếu muốn xem đầy đủ cả tải tập trung và tải phân bố trên màn hình thì vào menu Display ( Show Loads Assign ( Frame /Cable/Tendon…

Chọn trường hợp tải trọng cần xem lực tác dụng.
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3.5.7 Gán số lượng tiết diện xuất kết quả:

Nếu số tiết diện nhiều biểu đồ sẽ mịn và chính xác hơn, nhưng kết quả sẽ nhiều và khó theo dõi. Nếu số tiết diên ít, biểu đồ sẽ không chính xác và có dạng gãy khúc thay vì đường cong, nhưng bảng kết quả sẽ dễ quản lý hơn.

Do vậy  nếu để lấy kết quả là biểu đồ nội lực thì khai báo số tiết diện là một số khá lớn( khoảng 9-15 tiết diện mỗi thanh), nếu lấy kết quả là một bảng số liệu nội lực thì nên khai báo đối với dầm là 5 tiết diện.

Chọn các thanh cần thay đổi số tiết diện xuất nội lực (Assign(Frame (Out Station, hoặc chọn biểu tượng lệnh 
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3.5.8 Chạy chương trình tính:

- Khai báo dạng kết cấu: vào menu Analyze ( Set Analysis Option…
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Hệ dầm cũng được xem là hệ khung phẳng (kết cấu chịu uốn trong mặt phẳng XZ) nên ta chọn  [image: image231.png]PPPPP




Vào menu Analyze ( Run Analysis hoặc bấm   
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Sau khi chạy chương trình tính thì Sap sẽ khoá số liệu (biểu tượng khoá trên màn hình sẽ đóng lại [image: image234.png]


), nếu muốn sửa số liệu đã nhập thì phải mở khoá bằng cách bấm vào biểu tượng [image: image235.png]


, lúc đó sẽ trở thành [image: image236.png]


)

3.5.9 Xem kết quả nội lực, phản lực
Xem kết quả phản lực : vào menu Display ( Show Forces/Stresses ( Joints ... (hoặc bấm vào biểu tượng [image: image237.png]


 ( chọn Joints)
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Xem phản lực theo dạng liệt kê giá trị

[image: image239.png]59

ag

06!

E

011




 
Xem phản lực theo dạng mũi tên lực (Show as Arrows)

[image: image240.png]



Xem kết quả nội lực: vào menu Display ( Show Forces/Stresses ( Frames/Cables ... (biểu tượng [image: image241.png]


 ( chọn Frames/Cables)
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Biểu đồ momen M3-3 của tĩnh tải
Do SAP2000  qui định dấu của lực cắt ngược dấu với qui định của Việt Nam, nên khi xem biểu diễn lực cắt ta cần khai báo tỉ lệ mang dấu âm để đúng qui định.
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Biểu đồ lực cắt Q2-2 của tĩnh tải ( đã chỉnh tỷ lệ)
3.5.10 In kết quả phản lực, nội lực :


- In biểu đồ đang hiển thị trên màn hình : vào menu File ( Print Graphics 


- Xuất số liệu ra file Excel: vào menu Display ( Show Table…
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a. Chọn dữ liệu để xuất kết quả:

- Phản lực : ANALYSIS RESULTS ( Join Output ( Reactions ( Table: Join Reactions
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Nội lực trong thanh: ANALYSIS RESULTS ( Element Output ( FrameOutput ( Table:Element Force – Frame
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i2. Chọn trường hợp tải trọng hoặc tổ hợp tải trọng để xuất kết quả:
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Chọn các trường hợp tải trọng: Tĩnh tải(DEAD), HT1 ( HT6. Chọn OK để xuất kết quả 
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Vào menu File ( Export Current Table ( To Excel để xuất kết quả sang Excel 

Kết quả xuất sang Excel có dạng 
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Trong dầm chỉ cần lực cắt và momen do vậy chúng ta sẽ xóa các cột Case Type, P, V3, M2, FrameElem, ElemStaion. Chỉ sử dụng các cột Frame, Station, OutputCase, V2, M3.
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Do kết quả sắp xếp theo thứ tự tên phần tử nên khó theo dõi. Ta cần sắp xếp lại theo thứ tự của tên trường hợp tải. Cách sắp xếp như sau chọn các ô dữ liệu (kể thêm 1 hàng tiêu đề ). Chọn
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Thực hiện lệnh Data ( Sort: Chọn thứ tự sắp xếp theo Text của cột OutputCase.
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Kết quả sắp xếp như sau 
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Do dấu V2 ngược dấu với Q nên cần nhân V2 với -1 để dảo chiều. Cách thực hiện trong Excel như sau:


+ Nhập -1 vào 1 ô bất kỳ [image: image256.png]


Copy ô đó 

+ Chọn các ô dữ liệu cần đổi dấu:
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Thực hiện lệnh Paste Special chọn Value và Multiply
3.6 THỰC HÀNH 2: THIẾT KẾ KHUNG PHẲNG

Tính nội lực cho khung phẳng 4 tầng có kích thước và chịu tải trọng như hình vẽ. Vật liệu bê tông có cấp độ bền B20, E = 2.7×107kN/m2, γ = 25 kN/m3, υ = 0.2
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TĨNH TẢI
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HOẠT TẢI 1

[image: image262.emf]10kN/m


9kN/m


12kN


15kN


15kN


12kN


11kN/m


15kN


15kN


20kN/m


17kN/m


30kN


25kN


25kN


30kN


28kN


11kN/m


15kN


15kN




10kN/m 9kN/m

12kN 15kN 15kN 12kN

11kN/m

15kN 15kN

20kN/m 17kN/m

30kN 25kN 25kN 30kN 28kN

11kN/m

15kN 15kN


HOẠT TẢI 2
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GIÓ TRÁI
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3.6.1 Xây dựng mô hình kết cấu

B1: Chọn đơn vị tính kN,m, C

B2: Click menu File → New Model
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Chọn Grid Only, nhập thông số hình học.
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Nhấp đúp vào đường lưới, hiệu chỉnh lại đường lưới theo thông số bài toán.
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3.6.2 Khai báo điều kiện biên

Chọn những phần tử nút cần gán điều kiện biên

Click menu Assign → Joint → Restraints
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3.6.3 Định nghĩa vật liệu

Click menu Define → Materials → Add New Material
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3.6.4 Khai báo đặc trưng tiết diện, gán tiết diện cho phần tử

a. Khai báo tiết diện

Click menu Define → Section Properties → Frame Section→ Add New Property
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Tiết diện chữ nhật
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b. Vẽ các phần tử

c. Gán tiết diện cho phần tử: 

Chọn các phần tử cần gán tiết diện. Click menu Asign → Frame → Frame Sections → Chọn tiết diện → OK

3.6.5 Định nghĩa các trường hợp tải, gán tải trọng cho phần tử

a. Định nghĩa các trường hợp tải
Click menu Define → Load Patterns
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b. Gán tải trọng cho phần tử

Tải phân bố: Chọn thanh, vào menu Assign ( Frame Loads ( Distributed ... hoặc bấm vào biểu tượng [image: image279.png]
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Tải tập trung : Chọn nút, vào menu Assign ( Joint Loads ( Forces ... hoặc bấm vào biểu tượng [image: image281.png]
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Tĩnh tải:
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Hoạt tải 1:
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Hoạt tải 2:
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Tải gió trái:
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Tải gió phải:

[image: image287.png]



3.6.6 Định nghĩa các tổ hợp tải

Click menu Define → Load Combinations → Add New Combo

Ta có 12 ComBo:


COMB1: DL + LL1


COMB2: DL + LL2


COMB3: DL + GT


COMB4: DL + GP


COMB5: DL + LL1 +LL2


COMB6: DL + 0.9LL1 + 0.9GT


COMB7: DL + 0.9LL1 + 0.9GP


COMB8: DL + 0.9LL2 + 0.9GT


COMB9: DL + 0.9LL2 + 0.9GP


COMB10: DL + 0.9LL1 + 0.9LL2 + 0.9GT


COMB11: DL + 0.9LL1 + 0.9LL2 + 0.9GP


COMBBAO

3.6.7 Gán thông số giải bài toán

Đánh lại số thanh:


Edit → Change Labels  → Chọn Element Labels- Frame → Edit → Auto Relabels → All In List
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Khai báo số mặt cắt thanh:


Chọn thanh → vào Assign → Frame → Output Stations… 
Khai báo bậc tự do:


Vào Analyze ( Set Analysis Options ...  → Xuất hiện hộp thoại:
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Phân tích:


Vào Analyze ( Run Analysis  hoặc nhấn (F5)
3.6.8 Xuất kết quả nội lực

Xem kết quả phản lực : vào menu Display ( Show Forces/Stresses ( Joints ... (hoặc bấm vào biểu tượng [image: image290.png]


 ( chọn Joints)
Xem kết quả nội lực: vào menu Display ( Show Forces/Stresses ( Frames/Cables ... (biểu tượng [image: image291.png]


 ( chọn Frames/Cables)


Lực dọc trục (Axial Force):

[image: image292.png]



Lực cắt (Shear 2-2)

[image: image293.png]



Mô men (Moment 3-3)

[image: image294.png]



Xuất kết quả nội lực và tính thép xem lại Bài thực hành dầm liên tục
3.7 THỰC HÀNH 3: THIẾT KẾ KHUNG KHÔNG GIAN


Cho mặt bằng kết cấu công trình như hình vẽ, biết nhà 12 tầng.
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3.7.1 Chọn đơn vị tính
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3.7.2 Tạo sơ đồ tính
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*. Vẽ các điểm để vẽ cầu thang:
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*. Vẽ các thanh dầm qua các điểm ở khu vực cầu thang:


Chọn công cụ  [image: image305.png]


 vẽ dầm theo sơ đồ sau:
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*. Vẽ các ô sàn ở khu vực cầu thang:


Chọn công cụ  [image: image307.png]


 vẽ sàn theo sơ đồ sau:
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*. Sao chép các thanh dầm và sàn lên các tầng khác:
[image: image309.png]cut X

A

By conr aiec
[ pose.. v
x

Delete. Delete.

Add to Model From Template...
Ccti+E

Interactive Database Editing...

111 Replicat CtreR

[L3% Rephcate- . ~~~ CWPR




[image: image310.png]Replicate

[ T

Increments Replicate Optons

& o Modiy/Show Replicate Options.
PR 9of 9 active boes are selected

& [ I™ Delete Diiginal Objects

Increment Data
Number [36

Cancel





3.7.3 Khai báo vật liệu
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3.7.4 Khai báo tiết diện
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a. Khai báo tiết diện cột
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b. Khai báo tiết diện dầm
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c. Khai báo tiết diện sàn, vách

[image: image321.png]Define | Draw _ Select Assign Analyze Display Design Options
€ Materils.. Q Q& |W | x xyz

tion Properties To| Frame Sections
Section Properti » | TL Frame Sections.
€7 Mass Source... Tendon Sections...

Cable Sections...

Coordinate Systems/Grids...

< Area Sections.

227 Joint Constrains. |2, Areosectons..





[image: image322.png]Area Sections

Sections -~ Select Section Type ToAdd——
Shel E
515 N
Click t: bs

AddNewSecion
A Copy of Secion
odiy/Shon Section

Delle Secion

[





[image: image323.png]Shell Section Data

Section Name 515
Section Notes Modiy/Shon.

Disply Color I

Tope
@ Shell-Thin
€ Shel-Thick
€ Plate-Thin
€ Pate Thick
€ Membrane
€ Shell- Layered/Norlinear

L odip/Shon Loy Defnon. |

Wil
e
Mol nge —
ke

Herbione I Ca—
et C—

Concrete Shell Section Design Parameters

Madity/Show Shell Design Perameters

Stifness Madifrs

Set Modifers.

oK Cancel





3.7.5 Gán tiết diện


a. Gán tiết diện dầm, cột
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b. Gán tiết diện sàn, vách
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3.7.6 Khai báo điều kiện biên

Chuyển mặt bằng sàn về tầng (Base) chân cột như hình vẽ:
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Chọn các nút ở chân cột vào:
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Xuất hiện hộp thoại – chọn kiểu liên kết ngàm:
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3.7.7 Tạo tải trọng

a. Tĩnh tải:
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b. Hoạt tải:
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c. Gió:

[image: image335.png]Define Load Patterns.

Load Fatns
Sofwesn Ao Laad
Load Pattern Name Type. Multiplier Load Pattem
B3 o ] Nore
T oe i

Clck Te:

AddNew LoadPalem
Moy Load Patin %
oy LatralLoad Pater
Delele Load Patiern

Show Load Patter Notes.

ey





d. Động đất:
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3.7.8 Tạo tổ hợp


Để khai báo các tổ hợp tải trọng : vào menu Define ( Load Combinations ...
a. Tổ hợp cơ bản
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Xuất hiện hộp thoại:
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Kích chọn Add New Combo… xuất hiện hộp thoại:
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b. Tổ hợp bao

Kích vào Add New Combo… → Xuất hiện hộp thoại:
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3.7.9 Nhập tải trọng

3.7.9.1. Nhập tĩnh tải:
a. Tải phân bố trên dầm:
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b. Tải phân bố trên sàn:
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3.7.9.2. Nhập hoạt tải: (chỉ nhập hoạt tải trên sàn)
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3.7.9.3. Nhập tải trọng gió tĩnh: (tương tự như khung phẳng)

3.7.9.4. Nhập tải trọng gió động: (để tính toán được gió động xem mục 1.5.10, dưới đây chi nêu phương pháp nhập gió động)

Vào Define ( chọn Load Patterns… xuất hiện hộp thoại sau:

[image: image346.png]Clck Te:

AddNew Load Pattein

WodiyLoadPten |

Load Pattem Name. Type Muliplier Load Pattem
oX None. |

Moty Lateral Load Patern
Delete Load Pattein

Show Load Patter Notes.

ey






Chọn GX ( chọn User Defined ( kích Modify Load Pattern (
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Kích vào Modify Lateral Load Pattern xuất hiện bảng sau:
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Nhập các giá trị gió theo phương trục X vào cột FX, gió theo phương Y nhập tương tự.

3.7.9.5. Nhập tải trọng động đất: 

Vào Define ( chọn Load Patterns… xuất hiện hộp thoại sau:
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Chọn DDX ( chọn User Loads ( kích Modify Load Pattern (
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Kích vào Modify Lateral Load Pattern Xuất hiện bảng sau:
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Kích chọn Apply at Center of Mass ( Nhập các giá trị động đất theo phương trục X vào cột FX, động đất theo phương Y nhập tương tự
3.7.10 Tính toán dao động

a. Lựa chọn khối lượng:
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b. Phân tích giao động:
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c. Khai báo tâm cứng:
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d. Chia sàn và vách:
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e. Tính toán dao động:
- Khai báo bậc tư do
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- Tính toán
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f. Xuất kết quả tính toán dao động:
- Khai báo bậc tư do
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Sau khi có được các bảng kết quả tính toán dao động bởi file Excel hoặc Access ta tính toán gió động và động dất bằng các phần mềm khác hoặc lập phép tính trên Excel.

3.7.11 Tính toán nội lực
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Xuất hiện hộp thoại sau:
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Kích vào Run Now để tính toán

3.7.12  Tính toán thép
3.7.12.1. Tính toán thép trên Excel:

a. Xuất kết quả nội lực sang Excel:

Vào File → Export → SAP2000 MS Excel Spreadsheet.xls File → Xuất hiện:
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Kích chọn Element Output ( kích vào Select Load Cases… xuất hiện hộp thoại sau:
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Lựa chọn các trường hợp tải trọng hoặc tổ hợp muốn xuất nội lực:

Ví dụ: - Với dầm có thể chọn các tổ hợp như: TH1, TH2, …


- Với khung có thể chọn các trường hợp tải như: TT, HT, …

b. Tính toán thép trên bảng tính Excel:


Sao chép bảng kết quả vừa xuất vào bảng tính cốt thép mẫu (phần này tùy thuộc vào người lập công thức tính trên Excel)

3.7.12.2. Tính toán thép trên Sap2000 (sử dụng tiêu chuẩn của nước ngoài):

a. Chọn tiêu chuẩn thiết kế:
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Ví dụ chọn tiêu chuẩn CSA A23.3.04

b. Chọn các trường hợp tổ hợp đưa vào thiết kế:
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Chọn các tổ hợp từ cột List of Load Combinations ( kích vào Add để chuyển sang cột Design Load Combinations ( OK

c. Tính toán thép:
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Sau khi tính toán xong, chọn đơn vị Tonf.cm.C để xem kết quả (nên chuyển về khung phẳng để xem kết quả)

d. Xuất kết quả tính toán thép:

Vào File → Export → SAP2000 MS Excel Spreadsheet.xls File → Xuất hiện:
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Kích chọn Concrete Frame ( kích vào Select Load Cases… xuất hiện hộp thoại sau:
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PHẦN 2:THIẾT KẾ KẾT CẤU BẰNG PHẦN MỀM ETABS

CHƯƠNG 4. LÀM QUEN VỚI GIAO DIỆN PHẦN MỀM ETABS

4.1 GIỚI THIỆU TÓM TẮT VỀ PHẦN MỀM ETABS

4.1.1 Chức năng của phần mềm Etabs

Phần mềm Etabs được sử dụng để phân tích kết cấu các công trình xây dựng dân dụng, đặc biệt là nhà cao tầng. Nói như thế không có nghĩa rằng Etabs chỉ giải quyết được bài toán phân tích kết cấu cho nhà cao tầng, mà cần hiểu rằng Etabs được trang bị các công cụ để thực hiện việc phân tích kết cấu nhà cao tầng một cách thuận lợi nhất (so với các sản phẩm khác của hãng CSI).
Việc phân tích kết cấu cuối cùng nhằm mục đích tìm ra được nội lực (dùng để thiết kế cốt thép), phản lực (dùng để thiết kế móng), và các giá trị về chuyển vị (dùng để kiểm tra kết cấu ở trạng thái giới hạn về điều kiện sử dụng).
4.1.2 Các loại đối tượng trong Etabs

Trong Etabs, có hai đối tượng cơ bản đó là phần tử Frame (thanh) và phần tử Shell (tấm). Tùy thuộc phương của cấu kiện và đặc trưng chịu lực mà phần tử Shell còn được chia ra thành Slab (bản) và Wall (tường), tuy nhiên chúng đều thuộc chung một dạng phần tử đó là dạng tấm. Và mọi kết cấu trên thực tế đều có thể mô hình hóa bằng hai dạng phần tử này.
4.2 BẢNG CHỨC NĂNG CỦA CÁC BIỂU TƯỢNG
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	Ctrl + A
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4.3 NHỮNG CHÚ THÍCH CỦA CÁC MENU
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CHƯƠNG 5. CÁC QUY ĐỊNH CHUNG VỀ PHẦN MỀM ETABS

5.1 ĐƠN VỊ SỬ DỤNG:

Hệ đơn vị bao gồm đơn vị lực, chiều dài, nhiệt độ và thời gian.


- Lực: Ib, kip, N, kN, Kgf, Tonf


- Chiều dài : ft, in, m, cm, mm


- Nhiệt độ : F, C

- Thời gian : sec

Vào góc dưới phía bên phải màn hình:
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5.2 HỆ TỌA ĐỘ ĐỊA PHƯƠNG VÀ HỆ TỌA ĐỘ TỔNG THỂ:

5.2.1 Hệ tọa độ tổng thể (Global coordinate system)


- Các trục của hệ tọa độ tổng thể được quy ước là các trục X, Y, Z trong ETABS hệ tọa độ này có tên là GLOBAL.

[image: image434.png]




- Hệ tọa độ tổng thể có thể là hệ tọa độ vuông góc (Cartesian) và hệ tọa độ trụ Cylindrical)

[image: image435.png]
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Mặt bằng lưới hệ tọa độ vuông góc và hệ tọa độ trụ

5.2.2 Hệ tọa độ bổ sung

Hệ tọa độ bổ sung được dùng để dễ dàng cho quá trình mô hình một bộ phận nào đó của kết cấu. 

Define -> Coordinate Systems/Grids … -> Add New System
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5.2.3 Hệ tọa độ địa phương

Mỗi thành phần cơ bản của kết cấu (nút, phần tử, hay ràng buộc chuyển vị) đều có hệ tọa độ địa phương của chính nó. Các trục của hệ tọa độ địa phương được ký hiệu các trục 1, 2, 3.
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Hệ tọa độ địa phương của phần tử thanh
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Hệ tọa độ địa phương của phần tử tấm

5.3 NHỮNG CÔNG CỤ HỖ TRỢ XÂY DỰNG MÔ HÌNH:

5.3.1 Công cụ dùng để vẽ (Draw)


Chuyển sang chế độ chọn
Sửa đổi mô hình dạng phần tử

Vẽ thanh dầm qua 2 điểm

Vẽ nhanh thanh/Cáp giữa khoảng cách lưới

Vẽ cột khi kích vào 1 điểm trên mặt bằng

Vẽ dầm với khoảng cách đều nhau khi kích vào giữa ô lưới

Vẽ giằng
Vẽ sàn bất kỳ qua các điểm góc
Vẽ sàn chữ nhật qua 2 điểm 
Vẽ sàn chữ nhật khi kích vào trong ô lưới
Vẽ vách qua 2 điểm
Vẽ vách khi kích vào giữa khoảng cách lưới
5.3.2 Công cụ nhân bản phần tử, chia nhỏ phần tử và ghép phần tử (Edit)
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5.4 MÔ HÌNH HỆ KHUNG KHÔNG GIAN:

5.4.1 Thiết lập hệ lưới

a. Lựa chọn mô hình mẫu
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Chọn Default.edb xuất hiện hộp thoại sau:
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b. Sửa lưới theo phương trục X, Y
Nhập các thông số xong kích vào Custom Grid Spacing và Grid Labels như sau:
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Xuất hiện hộp thoại và sửa lại tên trục như hình dưới:
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- Beginning X ID nhập trục 1 (theo phương dọc nhà)


- Beginning X ID nhập trục A (theo phương ngang nhà)

Kích OK sau đó kích vào Edit Grid  để sửa lưới theo truc X và Y như sau:
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- Sửa lưới theo kiểu cộng dồn: Chọn Ordinates

- Sửa lưới theo từng khoảng cách: Chọn Spacing


- Sau khi sửa xong chọn Glue to Grid Lines ( OK

c. Sửa lưới theo phương trục Z (theo chiều cao tầng)

Trong hộp thoại ở mục (a) kích đánh dấu vào Custom Story Data sau đó chọn Edit Story Data như hình dưới:
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Xuất hiện hộp thoại sau:
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- Height: Chiều cao tầng (sửa đổi nếu có)


- Elevation: Cao trình của sàn tầng

- Master Story: Chọn làm tầng điển hình (Yes)


- Similar To: Chọn giống tầng điển hình nào (STORY?)

OK
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d. Chèn thêm lưới (thường dùng để thêm lưới vẽ dầm phụ)


Vào Edit ( Edit Grid Data ( Edit Grid … như sau:
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Xuất hiện hộp thoại:
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Kích chọn Modify/Show System xuất hiện hộp thoại sau:
[image: image454.png]Edit Format

¥ cut CtileX
B2 Copy Ct1+C. e | Line Type | Viskilly | Bubble Loc. | Grd Color
@ paste Ctrlev Pinay  Show Top
Pinay | Shw | Ton
Delete Delete
E Pinay | Shon | Top B
& Pinay | Shew | Top [
Delete Row
0 Pinay | Shew | Top [l
7
o
3
10
¥ GiidData
G0 | Ocede | UreTme | Vebly [BabeLoc| Giicz =
1 A Pinaty — — Shon —_Lsit
2 g —m
3 E Pinay | Show | Lot R
i o T e Gwela
5
3
7
o
3
10 |

o

Cancel

Urnis
Tonm

Display Giids a5
@ Dudinstes  Spacing

™ Hide AllGid Lines
Gl to G Lines

BubbleSize [125

Riesetto Defaul Color
Reorder Ordinates






Kích vào trục bên dưới vị trí muốn chèn dòng ( vào Edit chọn Insert Row như hộp thoại trên


Nhập khoảng cách lưới vào Ordinate và cột Line Type chọn Secondary:
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Kết quả sau khi thêm lưới:
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5.5 ĐẶC TRƯNG VẬT LIỆU

Vào Define ( Material Properties …
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Xuất hiện hộp thoại chọn CONC (bê tông cốt thép) ( kích vào Modify/Show Material.. như sau:
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Xuất hiện hộp thoại và nhập các thông số:
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Lưu ý: Các thông số nhập ở bảng trên được nhân với hệ số qui đổi từ tiêu chuẩn BS8110-97 sang tiêu chuẩn TCVN5574-2012 như sau:
- Đối với Bê tông: cường độ tính toán = 0.67*fcu/1.5

- Đối với Cốt thép: cường độ tính toán = fy/1.05

Ở đây 1.5 và 1.05 là hệ số an toàn riêng cho Bê tông và Cốt thép

Suy ngược lại, nếu bạn muốn khai báo vật liệu theo tiêu chuẩn Việt Nam, bạn cần khai báo cường độ tính toán đã nhân với các hệ số trên. Ví dụ:

- Với B15, R=85 kG/cm2 -> fcu khai báo sẽ bằng: 85*1.5/0.67 = 190.3 kG/cm3

- Với B20, R=115 kG/cm2 -> fcu khai báo sẽ bằng: 115*1.5/0.67 = 257.5 kG/cm2

- Với B25, R=145 kG/cm2 -> fcu khai báo sẽ bằng: 145*1.5/0.67 = 324.6 kG/cm2

- Với AII, R=2800 kG/cm2 -> fy khai báo sẽ bằng: 2800*1.05 = 2940 kG/cm2

- Với AIII, R=3650 kG/cm2 -> fy khai báo sẽ bằng: 3650*1.05 = 3832.5 kG/cm2

5.6 ĐẶC TRƯNG HÌNH HỌC:


Vào Define ( Frame Sections …
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Xuất hiện hộp thoại, xóa hết các tiết diện mẫu đã có như sau:
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5.6.1 Tiết diện cột:


Kích vào Add … chọn Add Rectangular xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)

- Nhập chiều cao cột (t3)


- Nhập bề rộng cột (t2)


Kích vào Reinforcement… xuất hiện hộp thoại sau :
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- Nhập khoảng cách từ tâm thép đến mép ngoài bê tông vào Cover to Rebar Center

- Nhập số lớp thép vào Number of Bars in …

5.6.2 Tiết diện dầm:


Kích vào Add … chọn Add Rectangular xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều cao dầm (t3)


- Nhập bề rộng dầm (t2)


Kích vào Reinforcement… xuất hiện hộp thoại sau :
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Nhập khoảng cách từ tâm thép đến mép ngoài bê tông vào Concrete Cover to Rebar Center (Top, Buttom)
5.6.3 Tiết diện sàn:


Vào Define ( Wall/Slab/Deck Sections …
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Xuất hiện hộp thoại, xóa hết các tiết diện mẫu như sau:
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Kích vào Add … chọn Add New Slab xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều dày sàn (Thickness)

5.6.4 Tiết diện tường, vách:

Vào Define ( Wall/Slab/Deck Sections …
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Kích vào Add … chọn Add New Wall xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều dày tường (Thickness)

5.7 VẼ SƠ ĐỒ TÍNH:

5.7.1 Vẽ cột: 
Chọn công cụ vẽ cột như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện (Property) ( kích vào điểm đặt cột trên mặt bằng các tầng

Chú ý: Nên vẽ nhiều tầng cùng lúc theo tầng điển hình chọn:
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Kết quả vẽ cột:
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5.7.2 Vẽ vách (tường): 
Chọn công cụ vẽ tường như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện tường (Property) ( kích vào 2 điểm vẽ tường trên mặt bằng các tầng
Kết quả vẽ tường:
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5.7.3 Vẽ dầm: 
Chọn công cụ vẽ dầm như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện dầm (Property) ( kích vào 2 điểm vẽ dầm trên mặt bằng các tầng
5.7.4 Vẽ sàn: 
Chọn công cụ vẽ dầm như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện sàn (Property) ( kích vào 2 điểm vẽ sàn trên mặt bằng các tầng như sau:
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Kết quả vẽ sàn:
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Chú ý: Nên chọn hiển thị sàn đặc để dễ phân biệt trong khi vẽ: View ( Set Building View Options  … ( Chọn Object Fill ( OK

5.8 CÁC DẠNG TẢI TRỌNG

5.8.1 Tĩnh tải: 

Vào Define ( Static Load Case... như sau:
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Xuất hiện hộp thoại sau:
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Vào cột Load nhập TT ( Type chọn DEAD ( Self Weight Multiplier nhập hệ số 1.1 ( Kích vào Modify Load.

5.8.2 Hoạt tải: 
Vào cột Load nhập HT ( Type chọn LIVE ( Kích vào Modify Load như sau:
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5.8.3 Gió tĩnh: 
Vào cột Load nhập GXT ( Type chọn WIND ( Kích vào Add New Load như sau:

[image: image487.png]Loads Clck Te:

SelfWeight Auto
Load Tope Mulipier  Lateral Load i Honlood
GxT [WND [ None =] Modiy Load

HT LIVE 0 Modify Lateral Load.
et Lons

ey





Gió tĩnh theo phương Y làm tương tự như trên với tên khác như: GYT
5.8.4 Gió động: 
Vào cột Load nhập GXD1 ( Type chọn WIND ( Kích vào Add New Load như sau:
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Gió động khác làm tương tự như trên với tên khác như: GXD2, GYD1, GYD2 như sau:
[image: image489.png]SelfWeight

Tope Multipier

Auto
Lateral Load

[

None
None
None
None
Nore.

F_

Clck Te:

oy oo
oy L Losd
et Lons

N

o

[y





5.8.5 Tải động đất: 
Vào cột Load nhập DDX1 ( Type chọn QUAKE ( Kích vào Add New Load như sau:
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5.9 MESH VÀ AUTOMESH CHO CÁC ĐỐI TƯỢNG SÀN:

Chọn sàn → vào Assign → Shell/Area → Area Object Mesh Option… 
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Kích chọn Auto Mesh Object into Structural Elements ( nhập số độ lớn khoảng chia sàn Further Subdivide Auto Mesh with Maximum Element Size of
5.10 MESH VÀ AUTOMESH CHO CÁC ĐỐI TƯỢNG VÁCH:

Chọn tường → vào Assign → Shell/Area → Area Object Mesh Option… như sau:
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Xuất hiện hộp thoại:
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Kích chọn Auto Mesh Object into Structural Elements ( nhập số độ lớn khoảng chia tường Further Subdivide Auto Mesh with Maximum Element Size of
5.11 TỔ HỢP TẢI TRỌNG

5.11.1 Tổ hợp cơ bản

Vào menu Define → Load Combinations.. như sau:
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Xuất hiện hộp thoại:
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Kích chọn Add New Combo… xuất hiện hộp thoại:
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5.11.2 Tổ hợp đặc biệt

Kích vào Add New Combo… → Xuất hiện hộp thoại:
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5.11.3 Tổ hợp bao

Kích vào Add New Combo… → Xuất hiện hộp thoại:
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5.12 ĐIỀU KIỆN BIÊN: 

Chuyển về mặt bằng BASE → Chọn tất cả các chân cột:
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Vào Assign ( Joint/Point ( Restraints (supports)… như sau:
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Xuất hiện hộp thoại:
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Chọn liên kết ngàm ( OK

5.13 NHẬP CÁC TRƯỜNG HỢP TẢI: (Tương tự như  SAP)
5.13.1 Nhập tĩnh tải: 

a. Tải trọng phân bố trên dầm:


Chọn dầm ( Vào Assign ( Frame/Line Loads ( Distributed… như sau:
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Xuất hiện hộp thoại:
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b. Tải phân bố trên sàn:


Chọn sàn ( Vào Assign ( Shell/Area Loads ( Uniform… như sau:
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Xuất hiện hộp thoại:
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5.13.2 Nhập hoạt tải: 

(Thông thường chỉ nhập hoạt tải phân bố trên sàn)

Chọn sàn ( Vào Assign ( Shell/Area Loads ( Uniform… như sau:
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Xuất hiện hộp thoại:
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Kết quả nhập hoạt tải:
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5.13.3 Nhập tải gió: 

a. Chọn tâm hình học:
Chọn tất cả các ô sàn trên mặt bằng STORY1(có thể chọn riêng từng tầng) ( Vào Assign ( Shell/Area ( Diaphragms… như sau:
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Xuất hiện hộp thoại:
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Kết quả chọn tâm hình học STORY1:
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Làm tương tự cho các tầng khác:

Chọn tất cả các ô sàn trên mặt bằng STORY2 ( Vào Assign ( Shell/Area ( Diaphragms…

[image: image512.png]Disphiagms.

NONE

Clck

‘AddNew Diaphragm
Modiy/Show Diaphragm

Delete Disphragm

T~ Disconnect from &l Diaphragms






Kích vào Add New Diaphragm xuất hiện hộp thoại:
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b. Nhập tải gió theo tâm hình học của các tầng:

Vào Define ( Static Load Cases … như sau:
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Xuất hiện hộp thoại:

Ví dụ: Nhập gió theo phương X:
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Chọn GX ( vào cột Auto Laterral Load chọn User Defined ( kích vào Modify Load   như hộp thoại sau:
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Tiếp tục kích vào Modify Lateral Load... xuất hiện hộp thoại:
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Nhập giá trị tải trọng vào tâm các tầng.

Ví dụ: Nhập gió theo phương Y: (tương tự như gió theo phương trục X)
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Nhập giá trị tải trọng vào tâm các tầng.

5.13.4 Nhập tải động đất: 


Vào menu Define -> Response Spectrum Functions… như sau:

[image: image520.png]ne Draw Select Assign Analyze
I MsterialProperti
T Frome Sections...
£ Wall/Slab/Deck Sections...
& Link Propertes.
Frame Nonlinear

inge Properties






Xuất hiện hộp thoại sau:

Trong mục Choose Function Type to Add, chọn Spectrum from File. Kích vào Add New Function xuất hiện hộp thoại sau:
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Trong mục Values are, chọn Period vs Value, kích Browe để chọn file, ví dụ chọn pho DD.txt như sau:
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Kích chọn pho DD.txt ( Open xuất hiện hộp thoại như sau:
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Sau khi chọn file, kích vào Display Graph để  Etabs đọc và biếu diễn phổ phản ứng gia tốc như sau:
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Có thể chọn Convert to User Defined để Etabs chép dữ liệu từ file này vào file *.EDB như sau:

[image: image525.png]= [

[
07544 Modiy
07317

8152 Delete
0838

08613

0932

0932

0932 v

4

- Function Graph

Dispey Graph G
Cancel





Khai báo xong phổ phản ứng gia tốc, nhiệm vụ tiếp theo là khai báo trường hợp tải trong động đất.
Vào menu Define -> Response Spectrum Case… như sau:
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Xuất hiện hộp thoại:
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Kích vào Add New Spectrum… xuất hiện hộp thoại:
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Trong mục Input Response Spectra, chọn phương tương ứng và nhập giá trị ở ô Scale Factor với giá trị phụ thuộc vào đơn vị đang sử dụng. Lưu ý rằng đơn vị mặc định của phổ phản ứng gia tốc là m/s2, nên nếu đang dùng đơn vị mm, bạn phải nhập giá trị 1000 vào ô Scale Factor.

Tiếp tục khai báo cho các phương khác, và từ đây bạn có thể đưa tải trọng vào tổ hợp như các trường hợp tải trọng khai báo thông thường.

5.14 TÍNH TOÁN TỔ HỢP NỘI LỰC:

5.14.1 Khai báo bậc tự do:

Vào Analyze ( Set Analysis Options ...  → Xuất hiện hộp thoại:
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Chọn Full 3D ( OK

5.14.2 Tính toán nội lực:

b. Tính toán:

Vào Analyze ( Run Analysis  hoặc nhấn (F5)
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c. Kết quả nội lực thanh:                       
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d. Kết quả phản lực tại gối: 
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5.15 TÍNH TOÁN THÉP THEO TIÊU CHUẨN NƯỚC NGOÀI
5.15.1 Chọn tiêu chuẩn thiết kế:

Vào Options → Preferences … → Concrete Frame Design.. Xuất hiện hộp thoại:
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5.15.2 Chọn những tổ hợp nội lực được đưa vào thiết kế thép:

Vào Design → Concrete Frame Design → Select Design Combo… Xuất hiện hộp thoại:
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5.15.3 Tính toán diện tích thép:

Vào Design → Concrete Frame Design → Start Design/Check of Structure… → sau đó chọn lại đơn vị Ton-cm: → Xem kết quả:
[image: image537.png]==

3-D View Deformed Shape (TT)

~|[GLOBAL < ][Torem ~

inactive,

X400.00 Y2492.56 Z3927.01

[ESRE=R SR

Elevation View - 2 Longitudinal Reinforcing (858110 97)

88888





CHƯƠNG 6.  TRÌNH TỰ NHẬP SỐ LIỆU VÀ PHÂN TÍCH MỘT SỐ BÀI TOÁN TRÊN PHẦN MỀM ETABS
6.1 GIỚI THIỆU CHUNG
ETABS là phần mềm kết cấu chuyên dụng trong tính toán và thiết kế nhà cao tầng. Đây là hệ chương trình phân tích và thiết kế kết cấu chuyên dụng trên máy tính cho các công trình dân dụng, ETABS được phát triển bởi CSI (Computers and Structures, Inc. Berkeley, California, USA).

Những điểm nổi trội của ETABS so với các chương trình khác trong phân tích kết cấu cho hệ thống công trình, sử dụng ETABS có thể đưa đến việc giảm rõ rệt thời gian yêu cầu trong việc xây dựng mô hình tính, giảm thời gian xử lý và tăng độ chính xác. Sở dĩ như vậy bởi vì ETABS thực hiện đưa vào các tính năng điển hình cho bài toán hệ các công trình dân dụng (công trình) trong xây dựng mà các hệ chương trình khác có thể không nhận ra.
Tính năng cơ bản của ETABS:

- Giao diện đồ hoạ thân thiện.
- Vào số liệu, chỉnh sửa và sao chép dễ dàng bởi hệ thống thực đơn, thanh công cụ.
- Tăng tốc nhập liệu nhà cao tầng bằng khái niệm tầng tương tự.
- Có thể mô hình các dạng kết cấu nhà cao tầng: Hệ kết cấu dầm, sàn, cột, vách toàn khối; Hệ kết cấu dầm, cột, sàn lắp ghép, lõi toàn khối…
- Sử dụng hệ lưới và các lựa chọn bắt điểm giống AutoCAD.
- Đánh hệ trục định vị mặt bằng kết cấu tự động.
- Xuất và nhập sơ đồ hình học từ môi trường AutoCAD
Chương trình ETABS hỗ trợ thiết kế kết cấu khung (tương tự SAP2000) theo các tiêu chuẩn mới của Mỹ và Châu Âu như:
- Tiêu chuẩn thiết kế kết cấu bê tông cốt thép:

+ ACI 318-05 (2005) and IBC2003 (2003): Tiêu chuẩn Hoa Kỳ;

+ Canadian CSA-A23.3-94 (1994): Tiêu chuẩn của Canada;

+ British BS 8110-97 (1997): Tiêu chuẩn của Anh quốc
+ Eurocode 2-2004: Tiêu chuẩn châu Âu;

…

- Tiêu chuẩn thiết kế kết cấu thép:

+ AISC360-05 (2005) and IBC2006 (2006): Tiêu chuẩn Hoa Kỳ;

+ CAN/CSA-S16-01 (2001): Tiêu chuẩn của Canada;

+ BS5950 (2000): Tiêu chuẩn của Anh quốc;

+ Eurocode 3-2005: Tiêu chuẩn châu Âu;
…
6.2 TRÌNH TỰ NHẬP DỮ LIỆU

6.2.1 Sơ đồ tính kết cấu

a. Chọn đơn vị:
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b. Nhập lưới:

Menu File → New Model  (hoặc Ctrl + N) xuất hiện hộp thoại:
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Chọn Default.edb xuất hiện hộp thoại sau:
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Nhập số nhịp theo phương trục X: Number Lines in X Direction

Nhập số nhịp theo phương trục Y: Number Lines in Y Direction

Nhập chiều dài nhịp theo phương trục X: Spacing in X Direction

Nhập chiều dài nhịp theo phương trục Y: Spacing in Y Direction

Nhập số tầng: Number of Stories

Nhập chiều cao tầng điển hình: Typical Story Height

Nhập chiều cao tầng dưới cùng: Buttom Story Height

c. Sửa tên trục và khoảng cách lưới theo trục X và Y:

Kích vào Custom Grid Spacing 

Kích vào Grid Labels xuất hiện hộp thoại:
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Đặt tên trục cho phù hợp với bản vẽ kiến trúc bắt đầu bằng chữ số 1, 2, 3, … hoặc bằng chữ cái A, B, C, … → OK

Kích vào Edit Grid xuất hiện hộp thoại:
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Sửa khoảng cách lưới cho phù hợp với bài toán → OK

d. Sửa chiều cao tầng và chọn tầng điển hình:

Kích vào Custom Story Data 

Kích vào Edit Story Data xuất hiện hộp thoại:
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Sửa chiều cao tầng: Height
Chọn tầng điển hình: Master Story (Yes) 

Chọn giống tầng điển hình: Similar To (Story ?)

→ OK

6.2.2 Nhập đặc trưng vật liệu

Vào Define ( Material Properties …Xuất hiện hộp thoại chọn CONC ( kích vào Modify/Show Material.. như sau:
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Xuất hiện hộp thoại và nhập các thông số vật liệu:
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6.2.3 Nhập đặc trưng tiết diện

Vào Define ( Frame Sections … Xuất hiện hộp thoại, xóa hết các tiết diện mẫu đã có như sau:
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a. Tiết diện cột:


Kích vào Add … chọn Add Rectangular xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Chọn vật liệu (Material)

- Nhập chiều cao cột (t3)


- Nhập bề rộng cột (t2)


Kích vào Reinforcement… xuất hiện hộp thoại sau :
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- Nhập khoảng cách từ tâm thép đến mép ngoài bê tông vào Cover to Rebar Center

- Nhập số lớp thép vào Number of Bars in …

b. Tiết diện dầm:


Kích vào Add … chọn Add Rectangular xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều cao dầm (t3)


- Nhập bề rộng dầm (t2)


Kích vào Reinforcement… xuất hiện hộp thoại sau :
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Nhập khoảng cách từ tâm thép đến mép ngoài bê tông vào Concrete Cover to Rebar Center (Top, Buttom)
c. Tiết diện sàn:


Vào Define ( Wall/Slab/Deck Sections …Xuất hiện hộp thoại, xóa hết các tiết diện mẫu như sau:
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Kích vào Add … chọn Add New Slab xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều dày sàn (Thickness)

d. Tiết diện tường, vách:


Vào Define ( Wall/Slab/Deck Sections …
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Kích vào Add … chọn Add New Wall xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều dày tường (Thickness)

6.2.4 Vẽ sơ đồ tính
a. Vẽ cột: 

Chọn công cụ vẽ cột như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện (Property) ( Nhập góc xoay cột (Angle) ( kích vào điểm đặt cột trên mặt bằng các tầng.

Chú ý: Nên vẽ nhiều tầng cùng lúc theo tầng điển hình chọn:
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b. Vẽ vách (tường): 

Chọn công cụ vẽ tường như sau:
[image: image558.png]




Xuất hiện hộp thoại:
[image: image559.png]Properties of Object

Type of Area
Properly

Plan Difset Nomal
(Auto Fler/Spandiel D57

Drawing Corlrol

N
None <space ban






Chọn tên tiết diện tường (Property) ( kích vào 2 điểm vẽ tường trên mặt bằng các tầng.

Chú ý: Nếu vẽ tường trên cửa thì chọn như sau:
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c. Vẽ dầm: 

Chọn công cụ vẽ dầm như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện dầm (Property) ( kích vào 2 điểm vẽ dầm trên mặt bằng các tầng
d. Vẽ sàn: 

Chọn công cụ vẽ dầm như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện sàn (Property) ( kích vào 2 điểm hoặc kích điểm giữa ô lưới vẽ sàn trên mặt bằng các tầng.
6.2.5 Nhập phần tử đặc biệt
Chọn thanh ( Vào Assign ( Frame/Line ( Frame Releases/Partial Fixity xuất hiện hộp thoại:
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Kích chọn mục loại bỏ nội lực đầu thanh, cuối thanh ( OK

6.2.6 Khai báo điều kiện biên
Chuyển mặt phẳng làm việc về BASE ( Chọn các nút chân cột và vách ( Vào Assign ( Joint/Point ( Restraints (Supports) xuất hiện hộp thoại:
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Kích chọn kiểu liên kết ( OK

6.2.7 Nhập tải trọng và chuyển vị cưỡng bức gối tựa

a. Tính toán tải trọng (tĩnh tải, hoạt tải): 


- Tạo tĩnh tải:

Vào Define ( Static Load Case... Xuất hiện hộp thoại sau:
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Vào cột Load nhập TT ( Type chọn DEAD ( Self Weight Multiplier nhập hệ số 1.1 ( Kích vào Modify Load.

- Tạo hoạt tải: 

Vào cột Load nhập HT ( Type chọn LIVE ( Kích vào Modify Load như sau:
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- Nhập tĩnh tải: 

+ Tải trọng phân bố trên dầm (tường xây trên dầm)


Chọn dầm ( Vào Assign ( Frame/Line Loads ( Distributed… Xuất hiện hộp thoại sau:
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Load Case Name: chọn TT


Load: Nhập giá trị tải trọng


+ Nhập tải trọng phân bố trên sàn (gồm các lớp cấu tạo sàn + trần, riêng bê tông phần mềm tự tính)


Chọn sàn ( Vào Assign ( Shell/Area Loads ( Uniform… Xuất hiện hộp thoại:
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Load Case Name: chọn TT


Load: Nhập giá trị tải trọng

- Nhập hoạt tải: 


Chọn sàn ( Vào Assign ( Shell/Area Loads ( Uniform… Xuất hiện hộp thoại:
[image: image571.png]T W‘—_[

-Uniform Load

Load 024 |
Ditection [Graviy E

Options
€ Add o Evisting Loads

@ Replacs Existing Loads
© Delte Existing Loads

Cancel





b. Tính toán dạng dao động: 

- Khai báo tâm cứng của sàn:

Chọn tất cả các ô sàn trên mặt bằng STORY?(có thể chọn riêng từng tầng) ( Vào Assign ( Shell/Area ( Diaphragms… Xuất hiện hộp thoại:
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( OK

- Khai báo khối lượng tham gia dao động:

Vào Define ( Mass  Source … Xuất hiện hộp thoại:
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- Phân tích động lực học:

Vào Analyze ( Set Analysis Options … Xuất hiện hộp thoại:
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Kích vào Set Dynamic Parameters ( Xuất hiện hộp thoại:
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- Tính toán dao động:

Vào Analyze ( Run Analysis (F5) … Xuất hiện hộp thoại:
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- Xem dạng dao động:

Vào Display ( Show Mode Shape … Xuất hiện hộp thoại:
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Chọn dạng dao động: Mode Number ( OK ( 
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c. Tính toán thành phần tĩnh của gió:





 
* Thành phần tĩnh của tải trọng gió W ở độ cao z: 




                                                       W =  * Wo * k * c





 
* Tải trọng gió qui về lực tập trung lên từng tầng: 




                   - Theo phương vuông góc cạnh dài:

TL = W * L * htầng


                   - Theo phương vuông góc cạnh ngắn:
TB = W * B * htầng


   
Trong đó:






   
+ Wo là giá trị áp lực gió tĩnh tiêu chuẩn, tại địa điểm xây dựng:  Wo (kG/m2)
   
+ k là hệ số kể đến sự thay đổi của áp lực gió theo độ cao và dạng địa hình lấy theo bảng 5. k được tra theo loại địa hình dạng (A, B, C).




   
+ c là hệ số khí động lấy theo bảng 6.

   
+  là hệ số độ tin cậy của tải trọng gió, lấy bằng: 1.2




  
+ L, B: kích thước cạnh dài, cạnh ngắn công trình (m)
d. Tính toán thành phần động của gió:





 
* Xuất kết quả tính dao động: 







Vào Display ( Show Tables… Xuất hiện hộp thoại:
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Kích chọn: 
Displacements




Modal Information




Building Output


( OK
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Nhập kết quả vào File Excel để tính gió động

e. Tính toán tải trọng động đất:





 
Mở file Earthquake.xls và nhập các thông số theo TCVN 9386-2012 như sau:
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Sau khi nhập xong cho kết quả sau:
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Sao chép kết quả của cột Period T và cột m/s2 vào file mới (ví dụ: pho DD.txt) như sau:

[image: image586.png]




Lưu file (pho DD.txt).

f. Gán tải trọng cho kết cấu:





 
- Tĩnh tải và hoạt tải đã nhập ở mục (a)

- Tải trọng gió: 


Vào Define ( Static Load Cases … Xuất hiện hộp thoại:

Ví dụ: Nhập gió theo phương X:

[image: image587.png]Clck Te:

Tope

SelfWeight
Multipier

Auto
Lateral Load

WD

=l

[

[ASCE 715
Mesican
Chinese 2010
15875 1987
EUROCODE ;
(AS/NZS 1170,

None

AddNew Load
Modiy Load
Moty Latersl Load

et Lons

ey






Chọn GX ( vào cột Auto Laterral Load chọn User Defined ( kích vào Modify Load   như hộp thoại sau:
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Tiếp tục kích vào Modify Lateral Load... xuất hiện hộp thoại:
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Nhập giá trị tải trọng vào cột FX.

Nhập gió theo phương Y: (tương tự như gió theo phương trục X) nhập giá trị vào cột FY.

- Nhập tải động đất: 


Vào menu Define -> Response Spectrum Functions… Xuất hiện hộp thoại sau:
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Trong mục Choose Function Type to Add, chọn Spectrum from File. Kích vào Add New Function xuất hiện hộp thoại sau:
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Trong mục Values are, chọn Period vs Value, kích Browe để chọn file, ví dụ chọn pho DD.txt như sau:
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Kích chọn pho DD.txt ( Open xuất hiện hộp thoại như sau:
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Sau khi chọn file ( Open, kích vào Display Graph để  Etabs đọc và biếu diễn phổ phản ứng gia tốc như trên.

Khai báo xong phổ phản ứng gia tốc, nhiệm vụ tiếp theo là khai báo trường hợp tải trong động đất.
Vào menu Define -> Response Spectrum Case… Xuất hiện hộp thoại:
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Kích vào Add New Spectrum… xuất hiện hộp thoại:
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Trong mục Input Response Spectra, chọn phương tương ứng và nhập giá trị ở ô Scale Factor với giá trị phụ thuộc vào đơn vị đang sử dụng. Lưu ý rằng đơn vị mặc định của phổ phản ứng gia tốc là m/s2, nên nếu đang dùng đơn vị mm, bạn phải nhập giá trị 1000 vào ô Scale Factor.

Tiếp tục khai báo cho các phương khác.

6.2.8 Tổ hợp tải trọng
Vào Define ( Load Combinations... Xuất hiện hộp thoại sau:
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Kích vào Add New Combo… xuất hiện hộp thoại:
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Một số tổ hợp tải trọng:


TH1
= TT + HT


TH2 
= TT + GX


TH3 
= TT + (-GX)


TH4 
= TT + GY


TH5 
= TT + (-GY)


TH6 
= TT + DDX


TH7 
= TT + (-DDX)


TH8 
= TT + DDY


TH9 
= TT + (-DDY)


TH10
= TT + 0.9HT + 0.9GX


TH11
= TT + 0.9HT + (-0.9GX)


TH12
= TT + 0.9HT + 0.9GY


TH13
= TT + 0.9HT + (-0.9GY)


TH14
= TT + 0.7GX + 0.7GY


TH15
= TT + (-0.7GX) + (-0.7GY)


TH16
= TT + 0.9HT + 0.63GX + 0.63GY


TH17
= TT + 0.9HT + (-0.63GX) + (-0.63GY)


TH18
= TT + 0.9HT + DDX


TH19
= TT + 0.9HT + (-DDX)


TH20
= TT + 0.9HT + DDY


TH21
= TT + 0.9HT + (-DDY)


- Tổ hợp bao:
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6.2.9 Nhập số liệu thiết kế
a. Chọn tiêu chuẩn thiết kế:

Vào Options → Preferences → Concete Frame Design … Xuất hiện hộp thoại:
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Trong hộp thoại này kích vào Design code: chọn BS8110 97 → OK
b. Chọn những tổ hợp nội lực được đưa vào thiết kế:

Vào Design → Concrete Frame Design → Select Design Combo… Xuất hiện hộp thoại:
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6.3 PHÂN TÍCH:

6.3.1 Chia lưới ô sàn:

Chọn tất cả các sàn → vào Assign → Shell/Area → Arra Object Mesh Option… 
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Kích chọn Auto Mesh Object into Structural Elements ( nhập số độ lớn khoảng chia sàn Further Subdivide Auto Mesh with Maximum Element Size of
6.3.2 Chia lưới vách:

Chọn tường → vào Assign → Shell/Area → Arra Object Mesh Option… Xuất hiện hộp thoại và làm tương tự như trên.

6.3.3 Tính toán nội lực:

Vào Analyze → Run Analysis (F5)

6.4 XEM KẾT QUẢ VÀ XUẤT THÀNH FILE:

6.4.1 Xem biểu đồ nội lực:

Vào Display → Show Member Forces/Stress Diagram → Frames/Pier/Spandrel Forces … Xuất hiện hộp thoại:
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Chọn loại nội lực cần xem ( OK

6.4.2 Kết quả phản lực tại gối:  
Vào Display → Show Member Forces/Stress Diagram → Support/Spring Reactions … Xuất hiện hộp thoại:
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6.4.3 Xuất kết quả thành File:

a. Xuất kết quả nội lực sang Excel:

Vào Display → Show Tables → Xuất hiện hộp thoại:
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Chọn Frame Output ( Kích vào Select Cases/Combos ( Xuất hiện hộp thoại:
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Chọn những tải trọng hoặc tổ hợp cần xuất ( OK ( Xuất hiện hộp thoại:
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Chọn loại cấu kiện cột (Column Forces) hoặc cấu kiện dầm (Beam Forces)


Nhấn Ctrl + C ( Mở File Excel ( Ctrl + V để chuyển qua.

b. Xuất kết quả nội lực sang Access:

Vào File → Export  → Save Input/Output as Access Database File  → Xuất hiện hộp thoại như ở mục (a).

Chọn những tải trọng hoặc tổ hợp cần xuất ( OK ( Xuất hiện hộp thoại:
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Nhập tên File ( Save

6.5 THỰC HÀNH 4: Thiết kế khung không gian có vách cứng
Tính toán nội lực cho công trình 15 tầng, chiều cao tầng dưới cùng là 4m, các tầng trên cao 3,2m. Tiết diện cột 60x60cm2, tiết diện dầm bxh = 25x60cm2, sàn bê tông cốt thép dày 12cm, vách cứng dày 30cm. Hoạt tải toàn phần tính toán phân bố đều trên sàn 2,4kN/m2, tĩnh tải tính toán phân bố đều trên sàn 1,5kN/m2, tải trọng gió tác dụng được xác định theo TCVN 2737-1995 có W0 = 0,83kN/m2, địa hình B. Vật liệu bê tông cấp độ bền B25, E = 3x107kN/m2, γ=25kN/m3, υ = 0,2.
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6.5.1 Chọn đơn vị tính
[image: image609.png]



6.5.2 Xây dựng mô hình kết cấu
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Chọn Default.edb xuất hiện hộp thoại sau:
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Nhấp đúp vào đường lưới để hiệu chỉnh: Chọn Display Grids as Spacing
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6.5.3 Định nghĩa vật liệu


Vào Define ( Material Properties …
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Xuất hiện hộp thoại chọn Add New Materia:
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Xuất hiện hộp thoại và nhập các thông số:

[image: image616.png]|- Display Color

Color

[~ Type of Mateial

@ Isotiopic Onhotopic

[~ Type of Desian

Design

Concrete _~/

- nalyss Property Data
Mass per urt Volure:
Weight peruritVolume
Modus of Elasily
Poissor's Ratio
Coelfof Thermal Expansion

Shear Modklus

25
=

[0000000.
T
[G900EDE
2500000

- Design Property Data (4C1 318.08/1BC 2009

Speciied Conc Comp Stiength, fc
Bending e, Yild Stess, fy
Shear Reint. Yield Stiess, s

T~ Lightweight Concrete.
Shesr Stiength Reduc. Factor

PEEEE
1368547
1368547

Cancel





6.5.4 Khai báo đặc trưng tiết diện, gán tiết diện cho phần tử

a. Dầm, cột


Vào Define ( Frame Sections …
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Xuất hiện hộp thoại, xóa hết các tiết diện mẫu đã có.

Kích vào Add … chọn Add Rectangular xuất hiện hộp thoại:
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b. Sàn

Vào Define ( Wall/Slab/Deck Sections …
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Xuất hiện hộp thoại, xóa hết các tiết diện mẫu như sau:
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Kích vào Add … chọn Add New Slab xuất hiện hộp thoại:
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- Nhập tên tiết diện (Section Name)


- Nhập chiều dày sàn (Thickness)
c. Tường, vách

Vào Define ( Wall/Slab/Deck Sections …
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Kích vào Add … chọn Add New Wall xuất hiện hộp thoại:
[image: image624.png]Wall/Slab Section

SectionName  [w30

Material 825 =~

Thickness
Merbrane o~
Bending o

Type
@ Shel  C Membrane (Pl
™ Tick Plate

Load Distibuton
™ Use Special One'Way Losd Distibution

SetModifers.|  Display Color I

s corca |






- Nhập tên tiết diện (Section Name)


- Nhập chiều dày tường (Thickness)

6.5.5 Vẽ sơ đồ tính
a. Vẽ cột :
Chọn công cụ vẽ cột như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện (Property) ( kích vào điểm đặt cột trên mặt bằng các tầng

Chú ý: Nên vẽ nhiều tầng cùng lúc theo tầng điển hình chọn:
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Kết quả vẽ cột:
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b. Vẽ vách

Vẽ các điểm để vẽ vách:
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Chọn công cụ vẽ tường như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện tường (Property) ( kích vào 2 điểm vẽ tường trên mặt bằng các tầng
Kết quả vẽ tường:
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c. Vẽ Dầm :
Chọn công cụ vẽ dầm như sau:
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Xuất hiện hộp thoại:
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Chọn tên tiết diện dầm (Property) ( kích vào 2 điểm vẽ dầm trên mặt bằng các tầng
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d. Vẽ Sàn

Chọn công cụ vẽ dầm như sau:
[image: image639.png]




Xuất hiện hộp thoại:
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Chọn tên tiết diện sàn (Property) ( kích vào 2 điểm vẽ sàn trên mặt bằng, tiếp tục vẽ các ô trống, kết quả như sau:
[image: image641.png]



6.5.6 Automesh các đối tượng sàn, vách

Chọn các đối tượng sàn, vách → vào Assign → Shell/Area → Arra Object Mesh Option… như sau:
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Xuất hiện hộp thoại:
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6.5.7 Khai báo điều kiện biên

Chuyển về mặt bằng BASE → Chọn tất cả các chân cột:
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Vào Assign ( Joint/Point ( Restraints (supports)… như sau:
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Xuất hiện hộp thoại:
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Chọn liên kết ngàm ( OK
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6.5.8 Khai báo Diaphragm


Chọn các đối tường dầm và sàn vào Assign ( Shell/Areas (Rigid Diaphragm
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6.5.9 Định nghĩa các trường hợp tải, gán tải trọng cho phần tử

a. Định nghĩa các trường hợp tải


Vào Define ( Static Load Case... như sau:
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Xuất hiện hộp thoại, vào cột Load nhập TT ( Nhập các loại tải trọng Type ( nhập hệ số Self Weight Multiplier
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b. Gán tải trọng cho phần tử
Tĩnh tải, hoạt tải :


Chọn sàn ( Vào Assign ( Shell/Area Loads ( Uniform… như sau:
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Xuất hiện hộp thoại, nhập tải cho từng trường hợp tải phân bố trên sàn :
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Tải gió :


Vào Define ( Static Load Cases … như sau:
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Xuất hiện hộp thoại:
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Chọn GX ( vào cột Auto Laterral Load chọn User Defined ( kích vào Modify Lateral Load
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Nhập giá trị tải trọng vào tâm các tầng.

6.5.10 Định nghĩa các tổ hợp tải

Vào menu Define → Load Combinations.. như sau:
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Xuất hiện hộp thoại:
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Kích chọn Add New Combo… xuất hiện hộp thoại:
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Ta có các tổ hợp như sau:



COMB1: DL + LL


COMB2: DL + WX



COMB3: DL + WY



COMB4: DL + 0.9LL + 0.9WX



COMB5: DL + 0.9LL + 0.9WY

6.5.11 Gán thông số giải bài toán

Vào Analyze ( Set Analysis Options ...  → Xuất hiện hộp thoại:
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Chọn Full 3D ( OK

Vào Analyze ( Run Analysis  hoặc nhấn (F5)
6.5.12 Xuất kết quả nội lực
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